[Ardour-Users] xruns??? or someting else makes my playhead freeze and Ardour crash

Wendy Van Wynsberghe re.mork at gmail.com
Tue May 22 06:46:28 PDT 2012

hello, gents,

I was on Ardour mailinglist digest mode - it took a day before your
answers arrived (bit silly of me)
I'll go over everything I have tried:

@fukked up

> I wouldn't recommend using a non-rt or realtime kernel with less than -p
> 512 and -n4 but that depends on your hw and further setup.
What is -n 4?

> I once had huge problems because of pulseaudio.
> To check if it's running, enter in the terminal:
> ps aux | grep pulseaudio
> if it's running,
> create ~/.pulse/client.conf with the following content:
> autospawn = no
> type
> pulseaudio -k
> into the terminal.
> start jack.
> hth
> /mn0

I have added this conf file - but it did not seem to do much (I could be wrong)

@ Robin Gareus

 ---> Starting jackd from the commandline (or use qjackctl) - take ardour out
 of the equation for now.

--> Play a simple audio. eg 'mplayer -ao jack some_file.wav'

Mplayer did not find jack (proably something simple, but the
commandline options of mplayer are a very dense forrest)

---> Try jackd in verbose mode: `jackd -v -d alsa` -  it's really verbose but
> some hints may be in there.

I have put the output of two different sessions here:

The first one gives xruns,
me at mycomputer:~$ jackd -v -d alsa
The second one a lot less
me at mycomputer:~$ pasuspender -- jackd -v -p 128 -R -P 60 -T -d alsa -n
4 -r 48000 -p 1024 -d hw:0,0
> It may be related to pulseaudio and/or the built-in soundcard. Those
> HDA-Intel cards are bad bad bad :)

---> I have already tried with other - external - soundcards and I had
the same xruns
pasuspender -- jackd -v -p 128 -R -P 60 -T -d alsa -n 4 -r 48000 -p
1024 -d hw:1,0
does not wan to work

@ Noel Darlow
avlinux, that's sounds like a summer plan ;-)
I'm also using Arduino, so, I'm a bit scared to change tooo much -
because that part works like a charm!


>You mention that you have a new core i3 .. try turning off all turbo
>boost settings .. and even powersaving settings in bios .... (there
>are more elegant ways around this but this could prove what is going
>wrong. )..

How do I set off turbo boost? Ididn't even know I had any ;-)
I'll have a browse on the web

IN the meantime  pasuspender -- ardour2 works a little bit better, but
the problem is no solved
----> And.. how do you tweak commandline jack and run ardour???

Because adding pasuspender to qjackctl was a total disaster

Thanks a lot already, I'll keep on trying..


More information about the Ardour-Users mailing list