[Ardour-Users] Adding tracks or busses disconnects Ardour from JACK

Q lists at quirq.ukfsn.org
Sat Oct 22 02:46:27 PDT 2011

On 09/10/11 11:18, Q wrote:
> Hi everyone
> I've recently upgraded my system from Ubuntu Studio 9.10 to a fresh
> install of Xubuntu 11.04 (with the Studio packages installed). I'm
> currently running the stock Xubuntu kernel.
> On the new system I've installed Ardour 2.8.12 using the installer from
> the Ardour website. I was using an older, but still fairly recent 2.8
> series IIRC, version under UbuStu. I'm now running Jack 0.120.1.
> Here's the problem. Whenever I try adding a track or bus Ardour usually,
> but not always, gets disconnected from Jack. This also occurs when
> trying to remove tracks or busses, or when changing the connections on
> existing tracks and busses to re-route stuff.
> This isn't isolated to a single session and these were both very light
> sessions with single-digit CPU loads.
> Is this an Ardour problem, a Jack problem or an OS problem? As you can
> see, there are quite a few new variables.
> Any idea of what the cause of the problem might be and how to resolve it?
> Thanks in advance
> Q

On 09/10/11 16:54, Q wrote:
 > I checked the Timeout, it was set to 2000. I expect it's probably
 > inherited this from my previous set-up (I keep the same /home partition
 > when I do a fresh install). I increased it to 5000 and it didn't make
 > any difference.

On 09/10/11 19:03, Q wrote:
 > These are old sessions, not ones created with 2.8.12.

On 09/10/11 19:12, Q wrote:
 > Renaming the .jackdrc and ardour.rc files had no effect, still
 > disconnected the moment I tried disconnecting a track from the Master
 > bus inputs.

On 13/10/11 20:21, Q wrote:
 > "Autoconnect inputs to physical inputs" was
 > enabled.
 > Sadly, switching it to manual did not stop Ardour disconnecting from
 > Jack when I tried to create a new track.
 > The funny thing is, I haven't been saving the sessions when Ardour gets
 > kicked out, yet when I re-open them not only is the new track still
 > there (hurrah for auto-save I guess), but it IS connected to the master
 > bus, which I wouldn't have expected.

Thanks to everyone who's made suggestions and offered help. I've tried a 
few more things.

On my old Ubuntu Studio 9.10 I didn't have Pulseaudio installed. I was 
surprised when I installed Xubuntu 11.04 (which hasn't solved my GPU 
lock-ups but that's another story) to find that PA worked, so I left it. 
Removing it and restarting had no effect on the Ardour problem.

Ubuntu's Ardour 2.8.11 works fine. I completely removed this and 2.8.12 
(I had them both installed) re-installed 2.8.12, restarted and the 
prolem still exists.

Obviously I can continue with 2.8.11, but I'd rather be using the latest 
stable version. By the way, I like the installer rather than having to 
compile it -- nice move. It's just my bloody luck that when I finally 
got around to donating/paying for Ardour I have problems with it. Oh 
well, that's sod's law for you :-)

Anybody got any further ideas or suggestions?



More information about the Ardour-Users mailing list