[Ardour-Users] Tranzport control surface under Ubuntu Studio 10.04

Brett McCoy idragosani at gmail.com
Thu Jan 13 20:03:04 PST 2011

Has anyone gotten the Tranzport to work under Ubuntu Studio 10.04
(kernel 2.6.32-25-generic)? I have tried every method listed on the
Ardour site but every time I try to enable in Ardour, I get the

       [ERROR]: control protocol name "Tranzport" could not be initialized

and a message to the console

       Tranzport: cannot claim USB interface

The device shows up under lsusb and the message

      ardour: [INFO]: Control surface protocol discovered: "Tranzport"

The device is created under /dev/bus/usb/<bus>/<dev>, like this:

crw-rw-r-- 1 root root 189, 386 2011-01-13 22:57 /dev/bus/usb/004/003

It always shows root:root permissions, even after setting up rules for
udev. But even running ardour as root I can't get Tranzport to work.
It worked fine when I'd previously had Fedora or Gentoo installed on
this very same machine a couple years back. but not under this distro.

Brett W. McCoy -- http://www.electricminstrel.com
"In the rhythm of music a secret is hidden; If I were to divulge it,
it would overturn the world."
    -- Jelaleddin Rumi

More information about the Ardour-Users mailing list