[Ardour-Users] jack and ardour disconnecting/crashing while using Csound

Hector Centeno hcengar at gmail.com
Wed Oct 22 23:16:41 PDT 2008


I just worked on a project that involved recording several tracks of
sound synthesized by Csound in realtime (tried both official 5.09 and
CVS build) plus ambisonic ladspa panners, ambdec (ambisonic decoder)
and jconv (convolution application). I started this project using
Ubuntu Studio Linux and ended it with OpenSuse (both using their
respective RT kernels and getting same problems with both). It became
a very unstable combination since every time I stopped Csound,
randomly Ardour would disconnect from jack or jack would crash, and
then I was unable to make Ardour reconnect after restarting jack (it
would complain about not being able to reconnect the ports). It was
happening so regularly that I had ready on my desktop a couple of
scripts to restart everything.

Is there anything I could do to avoid this? Is it Csounds fault? Is it
my system? Jack is running like this: jackd -R -P60 -p1024 -t2000 -u
-dfreebob -r48000 -p1024 -n3 -D (using a Edirol FA-101). Could this be
a realtime priorities issue? I installed the rtirq script by Rui Nuno
Capela tunned to prioritize the firewire ports and made sure Jack is
running at a lower priority (firewire is at 70). Jack's version is
0.109.2 and Ardour's is 2.5.

I will appreciate any help to make my system stabler.



More information about the Ardour-Users mailing list