[Ardour-Users] testing OS X native versions

matt at tinysongs.com matt at tinysongs.com
Fri Oct 5 05:01:56 PDT 2007

> On Thu, 2007-10-04 at 20:34 -0400, Matthew Polashek wrote:
>> I just tried to create a new session without making any changes at
>> all.  I suppose this is an unreasonable assumption at this point, but
>> new users will expect thing to "just work."  (I've been using Ardour
>> since one was required to compile a kernel in Linux form scratch but
>> not everyone will want to deal with any hickups.)
> well, there are 2 responses to this. first is: it depends on what the
> failure actually was. the console log is the way to find (thats where
> all the stdout/stderr ends up for GUI apps in OS X). if it shows "Cannot
> set sample rate to XXXX", then we have the culprit.

I'll look into it when I get home or tomorrow.  (Teaching today.  Going to
see a show tonight.)

> second is: the lack of a duplex device arrived in Tiger, not before, and
> it has bitten most OS X users on the nose. I don't know why Apple
> decided to go down this path. its interestingly similar to ALSA's very
> early design decision to have different devices for playback and
> capture. it messed up every piece of OS X software that, until that day,
> had worked by opening a single device and expected to get both
> operations.

Copy that.  Oh well.

>> >> Works with the MOTU but I can't configure the number of channels.
>> >> Default is 8 wich go to bank 1 of the 2408.
>> >
>> > I am suprised by all the people who ask about this. I really wasn't
>> > aware that so many people bother to configure the number of channels.
>> > The default should be *all* the available physical channels. Is
>> > there a
>> > problem with this?
>> All available physical channels on my 2408 is 24.  Only 8 showed up.
>> You do have a valid argument for not configuring however.
> What has happened with "regular" JACK until now?

I would normally configure QJackCtl with the number of channels I wanted
for I/O as well as latency, etc.  All were available and I've sucessfully
recorded and played back 24 tracks at a time in the past.

>> >> GUI seems slow.  Especially the scroll wheel of the mouse.
>> >
>> > in what direction(s) ? changing what? zoom? position?
>> I noticed initially that scrolling though the file system while
>> importing audio is extremely slow.  One flick of the mouse wheel and
>> I had to wait for the screen for a while.  Also present in adding
>> LADSPA plugs.  When recording, the edit window was very slow to begin
>> drawing waveforms - so much so that I made a double triple take to
>> see if it was rolling.  Record-enabling tracks was quite a wait as
>> well.  FYI, my video card is the original that came with the machine.
>> Also, apple-M bring up the mixer window but resizes it and places it
>> in the upper left corner.  I had the G-verb gui open and it was
>> kicked up into the upper left corner as well.
> these are likely legitimate bugs in the code that are being highlighted
> by apple's window manager. i'll fix these (its pretty easy).
>> Apple-` doesn't work to scroll through window.  (I think someone may
>> have noticed this already.)
> right, ardour by default uses ctrl-`, and gtk/osx has mapped all
> ctrl-FOO accelerators to apple-FOO (aka Command-FOO). so apple-` is
> stolen by Ardour.

I believe I was unclear.  Apple-` does not move between windows in Ardour
on my system in the new package.  It does in previous versions.


More information about the Ardour-Users mailing list