[ardour-users] [ardour-dev] ardour2 for macosx packaged up

Taybin Rutkin taybin at earthlink.net
Tue Jan 24 06:52:50 PST 2006

No, the package was misconfigured.  My fault.  I'll have a better one out shortly.


-----Original Message-----
>From: Neil Shaw <neilshaw at mac.com>
>Sent: Jan 24, 2006 8:06 AM
>To: ardour-users at lists.ardour.org
>Subject: [ardour-users]  [ardour-dev] ardour2 for macosx packaged up
>This package does not seem to run on my system. (although I have  
>noticed that someone else has managed to get it running)
>Clicking on the Ardour2 icon invokes X11 correctly and then Ardour  
>appears briefly in the dock while it tries to start and then it  
>vanishes (crashes)
>I have the FINK Commander installed on my system as well and it seems  
>to indicate that pango is installed.
>In the system log there is a statement that reads:
>     ' You may be able to recreate this file by running pango- 
>When I run pango-querymodules in a terminal window it does invoke but  
>the path does not get created. I have even built the path manually  
>and symbolically linked it to the path that pango seems to exist on  
>my system ('/sw/lib/pango/1.4.0/modules/pango.modules') but the  
>system still crashes with the same error.
>Any ideas as to what I have configured wrong?
>Thanks for your time in building this package
>Here is a copy of the system log:
>===== Tuesday, January 24, 2006 5:50:07 AM Canada/Mountain =====
>bash: no job control in this shell
>Ardour/GTK 2.0alpha1
>    (built using 1.0.2 with libardour 1.0.0 and GCC version 4.0.0  
>(Apple Computer, Inc. build 5026))
>Copyright (C) 1999-2005 Paul Davis
>Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren,  
>Joel Baker
>This is free software, and you are welcome to redistribute it
>under certain conditions; see the source for copying conditions.
>(ardour:1470): GLib-GObject-WARNING **: g_object_set_property: object  
>class `GtkSettings' has no property named `gtk-can-change-accels'
>(ardour:1470): Pango-WARNING **: No builtin or dynamically loaded  
>were found. Pango will not work correctly. This probably means
>there was an error in the creation of:
>   '/opt/local/etc/pango/pango.modules'
>You may be able to recreate this file by running pango-querymodules.
>(ardour:1470): Pango-CRITICAL **: _pango_engine_shape_shape:  
>assertion `PANGO_IS_FONT (font)' failed
>Pango-ERROR **: file shape.c: line 75 (pango_shape): assertion  
>failed: (glyphs->num_glyphs > 0)
>ardour-users mailing list
>ardour-users at lists.ardour.org

More information about the Ardour-Users mailing list