[ardour-users] Intel EM64T and Ardour+VST

George Chan george at goodmusic.ca
Sat Aug 26 13:48:07 PDT 2006

On Thu, 2006-08-24 at 16:47 +0100, Steven Chamberlain wrote:
> Andrew Johnston wrote:
> >I am currently running a gentoo 64 bit install on my AMD64 dual core
> >3800+. I do agree with the replies above, however I have chosen to
> >stay with 64 bit after trying to redo my gentoo install with 32bit,
> >and having huge problems.
> Have you tried making a 32-bit chroot? 
Yes, on Gentoo, but it didn't solve my problem of the occasional double
speed video files.

Also, on Slamd64 I had both 64bit & 32bit binaries, but I had major
problems with my RME 9632 audio card.

> On Debian this was quite easy for
> me. In /var/chroot I have a fairly minimal 32-bit Debian install in
> which I can compile and run software that only works in a 32-bit
> userland. But I don't believe I've ever had problems running ardour or
> ardour2 under a 64-bit userland -- except VST, because I couldn't get
> WINE to compile in 64-bit. Perhaps this has changed since then, or if
> not, it will no doubt work inside the 32-bit chroot. But with the huge
> amount of progress Linux audio is making these days, I can quite easily
> live without VST.

Ardour ran fine in 64bit, but without my RME card working properly, what
good was it?
> >The only problems I ever encounter is with JACK running my kernel
> >with SMP support (a well known but as of yet unfixed bug).  I also
> >find the system a little more unstable as a whole
> Snap!
> I've been having a lot of these kind of problems ever since I got my
> Athlon dual-core, but I didn't realise it was affecting other people.
> I had to go back to 2.6.16-rt29 to find some stability with SMP enabled,
> but I still battle with high latencies.
> >On 8/24/06, George Chan <george at goodmusic.ca> wrote:
> >>Most video codecs (like for mplayer, etc.) are available for 32bit
> >>ONLY.
> Again, I managed this with a 32-bit chroot. I'm not familiar with Gentoo
> but for Debian I found this guide helpful:
>    http://www.debian-administration.org/articles/356
> (though there is a mistake in the guide: '-arch' should be '--arch')
> >>Also, I was never able to get a low latency kernel working in
> >>64bit.  I tried something like 25(!) different configurations.
> >>Every single one hung at boot up.  On my single CPU, 32bit machine,
> >>the low latency kernel worked fine on my first try.
> Did you try a 64-bit, uniprocessor kernel? I had no problems with 64-bit
> rt- patched kernels until I got an Athlon X2 and enabled SMP. I think
> SMP kernels without the rt- patch were also stable.

I got some kernels without the RT patch to work, but none with the RT
patch.  I wouldn't even consider using a uniprocessor kernel on this
machine... what would be the point of spending the $$$ to use only one
processor?  But, in answer to your question, no, even a uniprocessor
kernel with the RT patch would hang.
> >>Also, there were intermittent problems with my video files playing
> >>back at double normal speeds.  Never was able to fix that one.
> Timer problems seem to be widely reported with Athlon dual-cores, though
> it's never affected me; apparently things can run at double speed (even
> the keyboard), or the system clock can speed up under higher CPU load.
> Your problem might be somehow related to that.

I'm not sure if this is an AMD specific problem.  I met other people
online who had the same issue, who had different hardware.

I've NEVER had so many problems with a Linux system... ever!
> Regards,

More information about the Ardour-Users mailing list