[ardour-users] Problems with Jack and Ardour/Rosegarden

Aapo Ville Antrea Romu aapo.romu at exitium.com
Wed Dec 8 14:41:31 PST 2004


Just solved my problem. 2 minutes ago!-) (I'll propably go out and throw
a party ;-)

As of your question, David, I have  Asus K8v Deluxe SE running AMD
Athlon 64 3000+ with 1GB of Kingston DDR400 memory and. As a boot drive
I have IBM DeskStar 20GB IDE drive. My root partition is on ReiserFS 3.6
at Promise SATA-150 controller with 2xSeagate Barracuda 7200.2 120GB
SATA-150 disks running Linux sofware RAID 0. They are all working fine.

My solution was to disable the onboard sound chipset and install SB
Audigy Platinum Ex to PCI slot 4 (only slot that does not share the IRQ
channel). I had the card standing unused on my another computer. Then I
just recompiled Jack and everything was working fine!

I suspect that the problem I had might been related to the fact that the
VIA82xxx sound card (onboard) did not have any latency setting when I
looked at it with lspci. Also I had Dlink WLan (ACX111) on my PCI4 slot
and now it is moved to the slot 2 sharing with Marvel Gigabit

Also I had to tweak modules.conf manually to load Audigy driver
(snd-emu10k1) at startup. Currently I'm loading snd-emu10k1-synth
manually. Should I add it to the modules.conf also? What should be the
alias for the driver? How do I get Alsa/Jack/another software to know
about the synth?

So. Only thing to resolve is how to get sound out of Rosegarden. Ardour
seems to work fine now.

Thank you all for your help!

Best Regards:

On Thu, 2004-12-02 at 17:19, David Snopek wrote:

> What motherboard do you have?  I have an AMD64 that got huge amounts of
> XRuns due to a buggy IDE controller.  After recompiling the kernel for my
> IDE chipset and removing the generic IDE driver, everything worked fine. 
> I am not at my home machine and can't give you the exact details.  But I
> have the ASUS K8V Deleuxe, for which the IDE chipset and on-board Marvel
> NIC are known problems.
> Also, the memory controller is on the chip NOT the motherboard with the
> AMD64.  It is also a little buggy and EXTREMELY picky about the memory you
> use.  I had to try three different brands before getting it to work
> stably.
> I hope this helps!
>   -- David Snopek
Exitium                  Email  aapo.romu at exitium.com
Aapo Romu                Mobile +358-44-5266603
Rautkallionkatu 12 A 70  http://www.exitium.com
01360 Vantaa             Europe, Finland

More information about the Ardour-Users mailing list