[ardour-users] x86_64, Ardour and LADSPA

David Snopek xevol at newtonave.net
Fri Dec 3 03:40:15 PST 2004

roger Depreeuw said:
>> David Snopek wrote:
>>> I run Ardour with all the LADSPA plugin packages I am aware of under
>>> Gentoo Linux on an Athlon64.  It works great!  Maybe, Fedora has
>>> problems?
>>>  My system is 100% 64-bit.  If yours is mixed 32/64 could that be it?
> I am intrested in your experience, as there is certainly future in
> 64-bit for audio recording.
> My questions are:
> Are you running on a dual processor system?
> Do you suffer from xruns, when running ardour with a heavy load?
> How is your system build (HW/SW).
> Apart from ardour do you use other apps?

As I mentioned in a different thread ("Problems with Jack and
Ardour/Rosegarden"), I had tons of problems getting my AMD64 system set up
stabily.  Mainly, the IDE chipset on my motherboard was buggy and, less
so,  the memory controller on the AMD64 chip itself.  After more than two
months of tinkering with kernel version/configurations and trying
different brands of memory it works _fanastic_ now.

Using Gentoo Linux, I have had no problems compiling apps for a pure
64-bit environment.  I also run Muse as my sequencer sync'd via jack to
Ardour.  I have not been able to get Rosegarden to work and after posting
several times to their mailing list found that other AMD64 users are
having the same problems.  Hopefully, this will get worked out soon.

Other audio apps I wire together via Jack/MIDI:
 - Hydrogen
 - AlsaModularSyth
 - QMidiArp
 - FluidSynth/qsynth
 - JAMin

I have a single processor 3200+ and a Detla 1010LT.  I use Xfce4 as my
desktop.  The only XRuns I get since solving all my problems are from
starting/stopping jack applications.

This was an upgrade from an AthlonXP system with most of the same hardware
and the difference is astronomical.  I have yet to push it passed its

Thank you.
  -- David Snopek

More information about the Ardour-Users mailing list