[ardour-dev] Compilation problem in last step

job at aarnolds.de job at aarnolds.de
Thu Aug 11 11:24:19 PDT 2005

Børre Gaup wrote:
> Gaskavahkku, borgemánu 10. b.  2005 23:22, job at aarnolds.de čálii:
>>Hi Esben,
>>thanks for your hint but I already got the CVS tarball of last night
>>today and tried it: same result as before. In the link step for
>>gtk_ardour/ardour.bin I get:
>>`.gnu.linkonce.t._ZN13StringPrivate11char_to_intEc' referenced in
>>section `.rodata' of gtk_ardour/ardour_ui.o: defined in discarded
>>section `.gnu.linkonce.t._ZN13StringPrivate11char_to_intEc' of
>>gtk_ardour/ardour_ui.o ...
>>over several dozen lines for nearly all object files that should be
>>linked together.
>>Kind regards,
> I had a similar problem. The solution that worked for me was to clean the 
> buildtree, using the command scons -c. This cleans away all the files that 
> has been created during compilation, leaving you with a clean source tree.
> After having done this, rebuild ardour, using scons.
> Hope this helps:-)
> Børre Gaup, Tromsø

Hi Børre,

thanks for your message, but unfortunately it didn't help. I even
installed a new 'scons' (0.96.90). No success. Perhaps there is a
C++/linker guru who can tell me how these symbols are built (I don't
find '_ZN13StringPrivate11char_to_intEc' in any library or source
file) or what means "referenced in section `.rodata' of ... defined
in discarded section": who defined it and who referenced it if not
the source code? An explanation to this may lead me to a solution.

Thanks a lot


More information about the Ardour-Dev mailing list