[ardour-dev] Compilation problem in last step

Børre Gaup boerre at skolelinux.no
Thu Aug 11 04:04:48 PDT 2005

Gaskavahkku, borgemánu 10. b.  2005 23:22, job at aarnolds.de čálii:
> Hi Esben,
> thanks for your hint but I already got the CVS tarball of last night
> today and tried it: same result as before. In the link step for
> gtk_ardour/ardour.bin I get:
> `.gnu.linkonce.t._ZN13StringPrivate11char_to_intEc' referenced in
> section `.rodata' of gtk_ardour/ardour_ui.o: defined in discarded
> section `.gnu.linkonce.t._ZN13StringPrivate11char_to_intEc' of
> gtk_ardour/ardour_ui.o ...
> over several dozen lines for nearly all object files that should be
> linked together.
> Kind regards,
> Ado
I had a similar problem. The solution that worked for me was to clean the 
buildtree, using the command scons -c. This cleans away all the files that 
has been created during compilation, leaving you with a clean source tree.

After having done this, rebuild ardour, using scons.

Hope this helps:-)

Børre Gaup, Tromsø

More information about the Ardour-Dev mailing list