[Ardour-Users] xruns invasion with firewire. kstudio 14 or 16

Damien Zammit damien at zamaudio.com
Mon Aug 8 11:13:14 PDT 2016

Be aware that 41000 is not a valid sample rate 44100 is.  Also in modern kernels after 4.5 there is alsa FireWire support for many devices YMMV. So to run without ffado you would use alsa backend.  Also check, if you are using ffado, that the alsa  FireWire drivers are not loaded or may interfere with streaming, good luck.
Damien Z

On 8 August 2016 9:54:20 PM AEST, Damien Delpiroux <xzurukneg at free.fr> wrote:
>Here a copy of my distress message send to ffado user's list. Maybe
>of you can explain log message or what to do for investigate.
>I'm so distraught. :/
>I need to record for a serious project, and now my recording with
>ardour4.7.0 is invaded by xruns!
>I use saffire pro 40 since 2012 without issues.
>The xruns are system dependent: no problem with 12.04, but with
>14.04 and 16.04 (same package, anyway).
>All that since midweek update (near wednesday 03/08/2016).
>I've tried other kernel (3.13-27 or -33 instead of last one) for 14.04:
>nothing better.
>And no other apps are runnig when I record with Ardour.
>Always, the xruns come by "package" (nearly 20):
>As you can see, it's cyclic: 10min ok, 20xruns, then 30min ok.. odd
>I've tried to learn more by jack in terminal, but
>jackd -P70 -dfirewire -dhw:1 -r41000 -p64 -n3  or
> jackd -P70 -dfirewire -r41000 -p64 -n3 or
>jackd -P70 -dfirewire -dhw:0 -r41000 -p64 -n3 -->all don't work!
>See: http://pastebin.com/hKgAxn0t
>Jack's log here, (divided):
>JackEngine::XRun: client = ardour was not finished, state = Running
> ERROR: JackAudioDriver::ProcessGraphAsyncMaster: Process error 
>--->what do that mean?
>The last thing, maybe the most important: I can't ear any noise with
>this xruns, even if I zoom max in ardour: nothing bad in the wave form!
>Is something broken on these system, or is jack become paranoiac?
>Anyway, I can't safely works in this conditions. Too tiring nervously.
>And can't check if this xruns are audible or not every times.
>Please help.
>Ardour-Users mailing list
>ardour-users at lists.ardour.org
>To unsubscribe  or change your mailing preferences please visit:

Sent from my Android device with K-9 Mail. Please excuse my brevity.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20160809/dcae3390/attachment-0002.htm>

More information about the Ardour-Users mailing list