[Ardour-Users] trouble with retaining microphone connectivity over multiple sessions in Ardou

Cameron Metcalf podeas at gmail.com
Wed Jun 24 09:08:47 PDT 2015

Ok. I was told at the time of purchase, last year, that this device would
work great with Linux.  I'll try to figure out how to isolate whether the
problem is with the external card, then or Ardour/qjack/Ubuntu studio.  It
seems, configuration-wise that the options have been exhausted.  I'm still
puzzled why it works the very first time, and then bails on subsequent
retries (I've tried different inputs and unpowered and repowered the sound
card itself, too).

Without intending to further derail: is there a standard/stable top 2 or 3
external sound cards that are preferred for recording in Linux environments
that anyone can personally vouch for?


On Wed, Jun 24, 2015 at 11:52 AM, Paul Davis <paul at linuxaudiosystems.com>

> Ardour and JACK do nothing to modify the configuration of the hardware
> mixer (if any) inside your audio interface.
> What you describe sounds more like a problem with the device driver than
> anything else - failing to re-initialize the hardware mixer to use the
> appropriate input configuration for the VSL.
> On Wed, Jun 24, 2015 at 11:37 AM, Cameron Metcalf <podeas at gmail.com>
> wrote:
>> Good point.
>> The microphone is Shure XLR, by the way...
>> I can hear it through headphones over VSL, so I know it is picking up
>> room noise.
>> There are two different inputs. I could be using on the sound card VSL
>> box: I have changed it between 1 and 2.
>> As stated, the very first time I use Ardour, it has no problem seeing the
>> box and recording from the microphone, all input levels are sensitive and
>> can be adjusted. On reboot, it apparently still sees the box (from all the
>> other points I've discussed), but the input levels are dead, the microphone
>> is capturing room noise, but Ardour is not showing any input level at all.
>> Cameron
>> On Wed, Jun 24, 2015 at 11:18 AM, Paul Davis <paul at linuxaudiosystems.com>
>> wrote:
>>> We need to get a few things clear.
>>> A microphone is a device that plugs into your VSL. The computer doesn't
>>> see the microphone, it sees the VSL. You could have nothing, or the mic, or
>>> an instrument plugged into the VSL .. the computer does not care.
>>> Thus ... I am really unclear on what you mean by "cannot detect the
>>> microphone".
>>> On Wed, Jun 24, 2015 at 11:08 AM, Cameron Metcalf <podeas at gmail.com>
>>> wrote:
>>>> Paul,
>>>> Thanks for specifying where to type in the device name.
>>>> I had selected the option "hw: VSL" from this dropdown earlier and then
>>>> moved the INPUT and OUTPUT selectors to "default". restarted jack, rebooted
>>>> the station, etc. But Ardour3 would still not detect the microphone, so I
>>>> went back and did re-select the specific INPUT and OUTPUT. I'm going to try
>>>> this again, later on today, though and re-enstate defaults for INPUT and
>>>> OUTPUT.
>>>> To restate the problem:
>>>> On a fresh install of Ubuntu studio, I accept all the defaults when
>>>> starting qjack, then Ardour3:
>>>> Ardour3 works perfectly and I can record from microphone that is fed
>>>> through the presonus external sound card. I can add as many tracks and play
>>>> them back no problem.
>>>> However on a system reboot (and subsequent reboots), the microphone is
>>>> no longer detected at all, when I add a new audio track and cue record, for
>>>> either an existing project or a new project, even though I have not changed
>>>> the configuration.  Then I verify that qjack is set to see my soundcard (by
>>>> name) as I have previously outlined, but Ardour3 still will not
>>>> detect/record from the microphone going through the external sound card.
>>>> Cameron
>>>> On Wed, Jun 24, 2015 at 8:03 AM, Paul Davis <paul at linuxaudiosystems.com
>>>> > wrote:
>>>>> On Tue, Jun 23, 2015 at 10:15 PM, Cameron Metcalf <podeas at gmail.com>
>>>>> wrote:
>>>>>> Paul,
>>>>>> I re-traced my steps. I had definitely read through:
>>>>>> http://jackaudio.org/faq/device_naming.html
>>>>>> a few times this past week and tried out (and have just RE-tried) the
>>>>>> following (after each change below, I re-run qjack and boot up Ardour to
>>>>>> see if the mic can be found)...
>>>>>> I run: cat /proc/asound/cards
>>>>>> and get:
>>>>>> 1 [VSL            ]: USB-Audio - AudioBox 22 VSL
>>>>>>                       PreSonus AudioBox 22 VSL at usb-0000:00:1d.7-3,
>>>>>> high speed
>>>>>> --
>>>>>> The conclusion of the FAQ page informs: "You can type it into the
>>>>>> device name selector in the upper left of qjacktl's setup dialog."
>>>>>> I do not see anyplace in qjacktl where I can literally type in a
>>>>>> device name selector. (I uninstalled an reinstalled qjacktl to try and look
>>>>>> for this again in case anything had been botched from other things I'd
>>>>>> changed).
>>>>>> After I click "setup" from qjacktl there is no place to type in a
>>>>>> device name selector. However, in the "Settings" tab, there are two
>>>>>> dropdown boxes for INPUT and OUTPU.  Both literally have "> hw:VSL"
>>>>>> selected already.
>>>>> You should NOT use the INPUT or OUTPUT selectors. They should never
>>>>> have been displayed so prominently. You need the "Interface" selector near
>>>>> the upper right of the setup dialog.
>>>>>> Out of desperation and just to see what would happen, I ran: jackd
>>>>>> -d alsa -d hw:VSL
>>>>>> from the command line. This did not resolve the problem.
>>>>> Well, that's correct. So I think you need to restate the problem ....
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20150624/914cb7db/attachment-0002.htm>

More information about the Ardour-Users mailing list