[Ardour-Users] How to set up mcu control surface in OSX?

Glarbl_Blarbl glarblblarbl at gmail.com
Tue Sep 8 18:05:07 PDT 2009

Yes, thanks again!  I just got around to looking at the wiki for the  
new manual, and I think this is a place where I can finally give back  
to the project.  Also it'll give me a chance to put that technical  
writing course I took to use ;)

So I'll go ahead and start on documenting the process for setting up  
an mcu control surface (osx and linux since I'll be setting up a linux  
box again soon too) when I have the time in the next couple weeks --  
after I skim the references on the front page on the wiki.  I imagine  
there aren't a lot of people who need to make these things work,  
making it a low priority as a bug.


On Sep 8, 2009, at 1:44 PM, Thomas Vecchione wrote:

> Well glad to hear it is working.  I guess I need to figure out what  
> I do by second nature these days to get the MCU working in the .rc  
> file and either submit a patch or at least document it in the new  
> manual.
>        Seablade
> On Tue, Sep 8, 2009 at 3:36 PM, Glarbl_Blarbl  
> <glarblblarbl at gmail.com> wrote:
> Thanks for the quick response!
> I reverted the .rc file to its original state, but I got this error:
> Sep  8 12:14:00 cabin [0x0-0xb80b8].org.ardour.Ardour2[1922]:  
> set_active to false because exception caught: The Mackie MCU driver  
> will not use a port with device=ardour
> I remember this error from linux, and the solution was to specify  
> the midi port in the .rc file.  So I went back to my custom .rc and  
> it connects again.
> As for reading the first time user's page, yes I did. There is  
> nothing on that page about the MIDI patchbay.  Regardless I  
> downloaded it and did as you suggested.  Now it works!
> Maybe I was remembering syncing my midi sequencer for the MTC stuff...
> Grant
> On Sep 8, 2009, at 8:14 AM, Thomas Vecchione wrote:
>> Going off memory the Mac doesn't need anything edited in the .rc  
>> file IIRC.  The build and install I believe sets it up correctly,  
>> but I will have to double check that sometime.  I don't remember  
>> editing anything the last couple of times I did this anyways.  Yes  
>> I am aware you need to edit it on Linux but the reason is that on  
>> Linux you ened to tell it to use the raw port, not the alsa-seq  
>> port which causes issues.
>> On Tue, Sep 8, 2009 at 1:48 AM, Glarbl_Blarbl  
>> <glarblblarbl at gmail.com> wrote:
>> The weird part is that even though it seems to recognize the  
>> control surface and map faders to mix channels, none of the faders  
>> move when I move them in the mix window (with or without feedback  
>> checked -- this works under linux) and I don't see any log activity  
>> when I move faders around on the mcu.  I tried Logic mode, MCU  
>> mode, and HUI mode all to no avail.
>> It sounds like you didn't read the part about using the MIDI  
>> Patchbay app on the first time OS X user page.  You need to  
>> download the MIDI Patchbay app, it can still be found on various  
>> points of the internet, and route from the mcu port to the MIDI  
>> port and Back, then enable feedback.
>> I have tried a bunch of different sync settings, but get errors  
>> when I try to "Send MTC" and sync mcu to MTC -- which is what I  
>> needed to do to make it work under linux.
>> Completely unrelated and should never be needed to get MCU working.
>>       Seablade

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20090908/0d359d29/attachment-0002.htm>

More information about the Ardour-Users mailing list