[Ardour-Users] Stuck at 2.8.0 ??? (for now)

Kevin Cosgrove kevinc at cosgroves.us
Thu Oct 8 10:56:13 PDT 2009

I think if I had a newer distribution than Mandriva 2007.0 that
I wouldn't be having these problems.  Not being able to upgrade
ardour would be yet one more reason to force me to upgrade.
Maybe someone can tell me if I have another way out.

I saw an email that says that 2.8.0 has a bug which can
cause file losses related to cleaning up unused files,
and that the trouble is fixed in later versions.  I built
2.8.0 just fine.  But, 2.8.1 and 2.8.2 compile OK but scons
won't complete the install step because of bug ID 0002718,
http://tracker.ardour.org/view.php?id=2718 like so

   mo_builder(["gtk2_ardour/nn_NO.mo"], ["gtk2_ardour/nn_NO.po"])
   msgfmt: gtk2_ardour/nn_NO.po: some header fields still have the initial default value
   msgfmt: found 1 fatal error
   scons: *** [gtk2_ardour/nn_NO.mo] Error 1

I see this is fixed in 2.0-ongoing, and I grabbed today's
SVN version 5756.  I verified that I have all of the tools
and libraries of the versions required of Ardour 2.0 here
http://www.ardour.org/building Running scons told me that I
needed to grab a newer libsndfile.  I have 1.0.17 installed.  It
looks like 2.0-ongoing (and 2.8.3?) needs 1.0.18 or better.

So, I grabbed 1.0.18 (also tried 1.0.19 and 1.0.20) and then I
ran into this problem:

   Making all in GSM610
   make[3]: Entering directory `/home/local/src/INCOMING/BUILD/libsndfile-1.0.18/src/GSM610'
   /bin/sh ../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../src     -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fomit-frame-pointer -march=i586 -mtune=pentiumpro -fasynchronous-unwind-tables -std=gnu99 -Wall -Wextra -Wdeclaration-after-statement -Wpointer-arith -funsigned-char -Wstrict-prototypes -Wmissing-prototypes -Waggregate-return -Wcast-align -Wcast-qual -Wnested-externs -Wshadow -Wbad-function-cast -Wwrite-strings  -pipe  -MT add.lo -MD -MP -MF .deps/add.Tpo -c -o add.lo add.c
   /bin/sh ../../libtool --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../src     -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fomit-frame-pointer -march=i586 -mtune=pentiumpro -fasynchronous-unwind-tables -std=gnu99 -Wall -Wextra -Wdeclaration-after-statement -Wpointer-arith -funsigned-char -Wstrict-prototypes -Wmissing-prototypes -Waggregate-return -Wcast-align -Wcast-qual -Wnested-externs -Wshadow -Wbad-function-cast -Wwrite-strings  -pipe  -MT decode.lo -MD -MP -MF .deps/decode.Tpo -c -o decode.lo decode.c
   ../../libtool: line 780: X--tag=CC: command not found
   ../../libtool: line 780: X--tag=CC: command not found

Which seems related to
http://www.mail-archive.com/libtool@gnu.org/msg10239.html which
is a pretty good discussion.

Then I tried something probably stupid, but maybe it would work.  I 
changed the sndfile requirement in SConstruct from 1.0.18 to 1.0.17 
which caused the scons build to fail after completing more steps, at 
this point

   g++ -o libs/ardour/session_export.os -c -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -pipe -DARCH_X86 -mmmx -m3dnow -march=i686 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS -Wall -DHAVE_LIBLO -Ilibs -DENABLE_NLS -D_REENTRANT -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -Ilibs -pthread -DUSE_RUBBERBAND -Woverloaded-virtual -DPACKAGE=\"libardour2\" -DLIBSIGC_DISABLE_DEPRECATED -DDATA_DIR=\"/usr/share\" -DMODULE_DIR=\"/usr/lib\" -DVAMP_DIR=\"/usr/lib/ardour2/vamp\" -DCONFIG_DIR=\"/etc\" -DLOCALEDIR=\"/usr/share/locale\" -DHAVE_JACK_CLIENT_OPEN -DHAVE_JACK_RECOMPUTE_LATENCIES -DHAVE_JACK_VIDEO_SUPPORT -DHAVE_JACK_PORT_ENSURE_MONITOR -DHAVE_WORDEXP -DHAVE_SYS_VFS_H -fPIC -Ilibs/pbd -I/usr/include/glib-2.0 -Ilibs/surfaces/control_protocol -Ilibs/midi++2 -Ilibs/vamp-sdk -Ilibs/sigc++2 -Ilibs/glibmm2 -I/usr/lib/glib-2.0/include -Ilibs/ardour -Ilibs/rubberband -I/usr/include/libxml2 libs/ardour/session_export.cc
   libs/ardour/session_export.cc: In member function ?int ARDOUR::AudioExportSpecification::prepare(nframes_t, nframes_t)?:
   libs/ardour/session_export.cc:173: error: ?SF_FORMAT_OGG? was not declared in this scope
   scons: *** [libs/ardour/session_export.os] Error 1
   scons: building terminated because of errors.

At this point I think I have two choices:

 - Continue with 2.8.0 and avoid cleaning up my old files.
 - Upgrade to a modern distribution which has or can build the 
   components required to build newer versions of ardour.

Any comments?

If you made it this far, thanks for reading!  Cheerio....


More information about the Ardour-Users mailing list