[Ardour-Users] xrun & automation

. m u r m e r . murmer at murmerings.com
Mon May 18 03:12:31 PDT 2009

thanks for this david!

David Adler wrote:
> 2nd version, more verbose:
> Not sure what you have done so far, a first step would be to
> give realtime privileges to your user by appending something
> like the following to /etc/limits.conf
> @audio   -  rtprio     99
> @audio   -  memlock    unlimited
> @audio   -  nice      -19

can i do this even without installing the rt kernel? i tried to take 
that step, but apparently the rt kernel is incompatible with my graphics 
card/driver. i spent several hours searching for a solution, but i can't 
find anything that works with the nvidia accelerated graphics driver 
version 173, which seems to be what my rather old card requires. i tried 
updating to driver version 180, which is in the repositories, but it 
didn't like it.

so - still running the generic kernel i took the steps you suggested. 
but even with these lines in limits.conf, jack won't start if i have the 
realtime checkbox checked. nor will it start if i raise the 
periods/buffer value to 3, which is something else i read improves 
performance with intel audio cards, such as mine. in both cases i get:

Could not connect to JACK server as client.
- Overall operation failed.
- Unable to connect to server.
Please check the messages window for more info.

ironic that this *is* in the message window, but there you go. ; )

i'm not certain i've got the syntax in my limits.conf file correct (bear 
with me, i'm really no programmer). the lines that were already present 
in the file are all preceded by '#', like this:

#* soft core 0
#root hard core 100000
#* hard rss 10000
#@student hard nproc 20
#@faculty soft nproc 20
#@faculty hard nproc 50
#ftp hard nproc 0
#ftp - chroot /ftp
#@student - maxlogins 4

those, obviously, ubuntu put there itself. but i thought the '#' tag was 
there to comment out any text, such as the term explanation at the top 
of the file? are these lines just there as an example, and not in use? 
or do all lines need to be preceded by '#'? basically, do i want:

@audio etc...


#@audio etc...

that said, i tried both, and couldn't start jack with the realtime 
checkbox checked either way. as far as latency is concerned, it's not a 
problem for me, i don't do *any* live recording to the machine, so i'm 
already running on a default of 4096. i'd go higher if jack would allow 
it. but i'm still getting regular xruns when in a session...

> The list archives of ubuntustudio and the linux-audio-user
> mailinglist contain much valuable information.
> Linux-audio-distributions are somewhat pre-optimised,
> there is a list here:
> http://wiki.linuxaudio.org/apps/categories/linux_audio_bundles_distributions
> I like 64studio -- but that's just my personal view.

thanks, i'll have a look at these...



|||  www.murmerings.com |||

More information about the Ardour-Users mailing list