[Ardour-Users] Missing shared object (that isn't missing)

Jonathan Stowe jns at its-going-to-be-fabulous.com
Wed Feb 25 01:59:24 PST 2009

2009/2/25 John Emmas <johne53 at tiscali.co.uk>:
> Porl,
> Thanks for the tip.  You were absolutely right and I would never have
> thought of this myself.  I'd like to understand what ldconfig actually did.
> Here's the sequence of events:-
> 1)  I restored a recently backed up partition which was (hopefully) an exact
> replica of its state prior to being backed up.
> 2)  I tried to run Ardour from a command line and discovered that it no
> longer worked.
> 3)  I took the main executable (ardour-2.4.1) plus 23 supporting shared
> objects and moved them somewhere safe.
> 4)  I rebuilt Ardour from source and did a fresh scons install.  The problem
> was still there.
> 5)  Next I ran "sudo ldconfig" which fixed the problem.
> But here's the puzzling thing:-  Now that it's working, I've been able to
> delete all the modules I built yesterday, restore the ones that I'd moved to
> a safe location (the ones that originally exhibited the problem) and they
> now work too!!  So whatever ldconfig does, it doesn't seem to modify the
> (non working) executable or its shared objects.  So what exactly has it
> done?

ldconfig creates a "cache" (usually in /etc/ld.so.cache) of the
dynamic libraries found in it's search path - it will also fix up the
links to the versioned libraries if necessary.

http://rabidgravy.com/ - Music
http://gellyfish.co.uk/ - Everything else

More information about the Ardour-Users mailing list