[Ardour-Users] Ardour dependency dance,

Henry W. Peters hwpeters at jamadots.com
Tue Dec 15 08:57:18 PST 2009

Thanks All for replies, suggestions, etc.,

I got some advise from someone on the GTK list... try 'make uninstall,' 
& after I remembered you cd to the directory the 'make' file is in (easy 
for me to forget this command in the heat of the uncertainties of a 
relatively new setup), it worked very well, & after the usual .dev 
file/s not installed, were found & installed, Ardour 2.84 got built & 

First step accomplished, though I still have sound input from my spdif 
input issues (!!). I'll work at it, but I may be back here around this 
now, chronic problem (& I even tried it out in my xfce desktop 
environment, where supposedly Pulse audio is not supposed to be utilized).

Thanks again.


Henry W. Peters wrote:
>> *checking for GLIB - version >= 2.21.3...
>> *** 'pkg-config --modversion glib-2.0' returned 2.22.0, but GLIB (2.22.3)
>> *** was found! *If pkg-config was correct, then it is best
>> *** to remove the old version of GLib.
> I'm giving Ardour another try, now, on Debian Lenny...  Trying to 
> install the GTK libraries, to satisfy all dependencies, to be able to 
> build & install Ardour from source,  I get the above error (in bold). 
> The first time I did an install of the GLIB files (*GLIB (2.22.3)*), I 
> may have messed up (didn't read the 'install' file, my bad), & did 
> /not/ do  the 'rm -rf/install-' etc. as indicated below...  so I tried 
> again (after doing a 'make clean'), hoping this will not mess me up 
> too bad! (?) & perhaps this is not the problem anyway... (but then 
> again...?) Any suggestions?
> Thanks,
> Henry

More information about the Ardour-Users mailing list