[Ardour-Users] jack and ardour disconnecting/crashing while using Csound

Ralf Mardorf ralf.mardorf at alice-dsl.net
Thu Oct 23 03:07:46 PDT 2008

Hector Centeno wrote:
> Hello,
> I just worked on a project that involved recording several tracks of
> sound synthesized by Csound in realtime (tried both official 5.09 and
> CVS build) plus ambisonic ladspa panners, ambdec (ambisonic decoder)
> and jconv (convolution application). I started this project using
> Ubuntu Studio Linux and ended it with OpenSuse (both using their
> respective RT kernels and getting same problems with both). It became
> a very unstable combination since every time I stopped Csound,
> randomly Ardour would disconnect from jack or jack would crash, and
> then I was unable to make Ardour reconnect after restarting jack (it
> would complain about not being able to reconnect the ports). It was
> happening so regularly that I had ready on my desktop a couple of
> scripts to restart everything.
> Is there anything I could do to avoid this? Is it Csounds fault? Is it
> my system? Jack is running like this: jackd -R -P60 -p1024 -t2000 -u
> -dfreebob -r48000 -p1024 -n3 -D (using a Edirol FA-101). Could this be
> a realtime priorities issue? I installed the rtirq script by Rui Nuno
> Capela tunned to prioritize the firewire ports and made sure Jack is
> running at a lower priority (firewire is at 70). Jack's version is
> 0.109.2 and Ardour's is 2.5.
> I will appreciate any help to make my system stabler.
> Thanks!
> Hector

Hi Hector :)

this is one of the problems I had, when I was using Rosegarden and not
Ardour. I used the Fluidsynth-DSSI and Qsampler. Sometimes Jack didn't
crash and only Rosegarden crashed after there was a MIDI input or an
audio recording.

I was thinking of using the Atari's Cubase 3.1 synced by MTC with
Ardour, because I also have troubles with other sequencers. I did a
first short test and the Atari seems to be in time when running as
slave, but it seems to be impossible to run Ardour as slave.

Doing short tests Jack was stable for Suse 11.0 latest RT and jackd, I'm
upgrading with OSS, Non-OSS, Updates, Packman and Videolan, but nothing
else enabled. QjackCtl is the cvs version, I guess it's, I
can't tell you right now, because I'm at the moment running 64 Studio,
where I also have the troubles with Jack when running Rosegarden or MusE.

I made a 'simple' recording using Ardour without virtual synth some
weeks ago. I can't remember if I used 64 Studio or Suse, but I guess I
used Suse with an older RT kernel and everything was stable, I was
running Gverb and JAMin too.

I hope I won't get problems when doing 'heavy' recordings with Ardour,
while running virtual synth on my Linux, that will be controlled by the
Atari's Cubase.

I just want to let you know, that I'm heaving this troubles with Jack
too, but until now it only seems to happen, when I'm running Rosegarden.

My mobo is an ASUS M2A-VM HDMI, unfortunately using the on-board
graphics. The CPU is an Athlon X2 BE-2350 G2.

Someone from the 64 Studio list is using some actual Intel hardware. I
can't say if he has exactly the same troubles, but he has got troubles
with sequencers too, while Ardour is fine for Arch and Sidux.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20081023/f0c1be06/attachment-0002.pgp>

More information about the Ardour-Users mailing list