[Ardour-Users] Can't compile 2.5

Doug McLain doug at nostar.net
Sun Jul 13 02:39:18 PDT 2008

That jack function is part of the time api stuff added in 0.109.0, so 
you need at least 0.109.0.  You should should grab the latest release 
which is 109.2 and concentrate on making it run right.  If ardour 
wouldn't build and jack segfaulted on startup when you tried to install 
the later version, I suspect you had leftovers from earlier version of 
jack laying around.  It's very important to make sure that older 
versions of jack are completely removed when upgrading.  That means no 
jack libs in /lib, /usr/lib, /usr/local/lib; no headers in /usr/include 
or /usr/local/include, and no jack bins in any of the bin paths.  If you 
are installing jack from some sort of package, still make sure no old 
version s are lying around, and then install both the jack package and 
its -devel package.


Matt Savigear wrote:
> Hi all,
> I'm currently trying to upgrade to 2.5 (on a Gentoo x86_64 setup), but 
> compilation halts with the following error:
> libs/ardour/globals.cc: In function 'ARDOUR::microseconds_t 
> ARDOUR::get_microseconds()':
> libs/ardour/globals.cc:386: error: 'jack_get_time' was not declared in 
> this scope
> scons: *** [libs/ardour/globals.os] Error 1
> scons: building terminated because of errors.
> According to the bug database I might need a newer version of jack but I 
> get the same error with either 0.103.0 (which runs on my system) or 
> 0.109.2-r1 (which segfaults along with the rest of the 109 series when I 
> try to start it, hence my use of 103).
> Can anyone suggest what might be going wrong?

More information about the Ardour-Users mailing list