[ardour-users] Ardour 2.0 and BCF2000

Kevin Cosgrove kevinc at doink.com
Fri May 18 14:26:18 PDT 2007

On 17 May 2007 at 20:11, Paul Davis <paul at linuxaudiosystems.com> wrote:
> the first thing to check is that MIDI messages are getting through.
> Windows->Options Editor->MIDI->trace input (for the mcu port)
> then move the faders, and check in the terminal window where
> you started ardour.
> second, you need to enable either Generic MIDI control or Mackie Control
> protocols under Options->Surfaces. Assuming that you use Generic MIDI
> for the moment, you can then ctrl-middle click on a fader, wiggle the
> physical fader, and the binding should be established.

I got it working!  But, it only works with ardour 2.0rc1 -- it might 
work with prior versions, but I didn't try anything older than that.
This line in ardour.rc is required:

<MIDI-port tag="mcu" device="/dev/snd/midiC3D0" type="alsa/raw" mode="duplex"/>

I also have this line in ardour.rc, but I don't know if it's needed:

<Option name="mackie-emulation" value="bcf"/>

When I start ardour2 Generic MIDI is enabled under Options -> Surfaces.
As soon as I also enable Mackie Control under Options -> Surfaces 
then the BCF2000 faders assume the positions of the faders in
ardour's mixer window.  The top buttons of the BCF2000 control
things like mute, record enable, etc, and the top dials control
panning.  Moving something on either the BCF2000 or in ardour has
a corresponding, maybe expected response.  So, I think all seems
well on my system with 2.0rc1 and my BCF2000.

With 2.0rc1 when I "trace input" for "mcu" and move a control on the 
BCF2000 then I get a whole bunch of diagnostics messages in the xterm
where I started ardour.

The bad news is that once I run ardour 2.0rc2 or 2.0.2 then the 
working "mcu" line in my ardour.rc file is removed and replaced by:

<MIDI-port tag="mcu" device="ardour" type="alsa/sequencer" mode="duplex"/>

ardour (2.0rc2 nor 2.0.2) doesn't seem to let me add the "mcu"
line back in that actually works on my system. "trace input"
results in no messages in my xterm.  It's somewhat odd that
when I try to bind a slider that from then on all the BCF2000
sliders want to stay all the way down.  When I wiggle the
various sliders, then the master ardour slider moves to slightly
different positions.  The BCF's channel 1 slider moves it down by
a small fraction, slider 2 moves by less, and so on.  Touching
the various sliders causes the master to move to a somehow
prescribed position, not smoothly controlling the position.

At this point my guess is that my MIDI patch bay stuff is busted,
even though I just recompiled qjackctl to get the MIDI tab to
appear functional.  I'm running ALSA 1.0.12 (from Mandriva) and a
multimedia version of the SMP kernel (from Mandriva's
contrib repository) on an Athlon 64-X2.  If it matters, I've
compiled every version of ardour that I run.

Does anyone else also think the problem lies in my MIDI patch bay?

Would it be better to take these questions over to the mailing
lists for Linux audio users or ALSA users?



More information about the Ardour-Users mailing list