[ardour-users] bcf2000 + ardour2.0.2 problems

Kevin Cosgrove kevinc at doink.com
Fri Jun 1 13:28:20 PDT 2007

On 1 June 2007 at 21:19, John Anderson <ardour at semiosix.com> wrote:

> > Kevin Cosgrove wrote:
> > > So fellas (Josh Parsons, John Moore Liles, Joe Hartley)
> > > each of you has some experience with the BCF2000 and ardour
> > > 2.0.2....
> It works for me with 2.0-ongoing (and nothing has changed in
> the actual driver since rc2) if I do the following:

Hmm, the latest version that works straight away for me is rc1.

> - put BCF into Logic Control mode
> - start ardour
> - connect BCF port to ardour:mcu port (both directions) with something
> like qjackctl
> - turn on Control Surfaces/Mackie

That's exactly the recipe I started with, which works fine in
rc1, but not for me with anything after rc1.  But, see the recent
thread about how 2.0.2 works for me with the BCF in b-control
mode and ardour conversing generic MIDI with the BCF.

> If you don't like doing the port connection dance (I don't),

I don't like that dance either, but since ardour 2 requires me
to start jack before and independently of ardour, then doing
that dance isn't any incremental hassle.  And really, the hassle
hasn't been enough for me to script around it or anything, i.e.
it's only a very minor annoyance.

> you should also be able to add a port definition like this to
> ardour.rc:
> <MIDI-port tag="mcu" device="/dev/snd/midiC2D0" type="alsa/raw" mode="duplex"/

I've tried that, with C3D0 for where my BCF resides in the card

> but ardour seems to keep overwriting it with the alsa/sequencer
> definition. If that's the case it's a bug.

Have you confirmed that ardour 2 leaves that ardour.rc line alone
for you?  I've tried quite a few times and it always replaces
that line with device agnostic line.

Thanks again...


More information about the Ardour-Users mailing list