[ardour-users] A decent sound card for Ardour

John Emmas johne53 at tiscali.co.uk
Fri Feb 9 00:55:46 PST 2007

Hi Andrew - here are my answers to your questions....

> 1) What is your hardware that you have connected to the RME, and
> how have you connected it?
Currently, I just have a pair of self powered speakers connected to analog
outputs 1&2.  I'm not trying to do anything fancy, just hear some sound.

> 2) When you speak into your microphone do you get any levels appearing in
> the hdspmixer 'input' section.
I've not even attempted to make an input yet.  I'm just trying to get an
output from pre-existing sounds such as WAV files, system beeps etc.

> 3) When you play audio from a jack connected application, do you see
> levels in the second section of the hdsmpixer called 'playback'.
That one's difficult to answer because at the moment, I don't know enough
about Linux audio to know which applications are jack aware.  However....
OpenSUSE - hdspmixer isn't installed yet.  I only installed the OS last
night.  I'll come back to you later on that one.
Ubuntu - If I open hdspmixer and then double-click on a known sound file
(such as a WAV) it opens another application called Totem Movie Player.
This shows a progress bar and the meters show a signal (in the middle
section only) of hdspmixer.  Jack isn't installed yet under Ubuntu and
AFAIK, Totem Movie Player doesn't need it.

> 4) Are there levels appearing in the bottom section of the hdspmixer
> called 'output'.  If not then this is why you aren't hearing any audio.
No, this is the problem.  Nothing appears on the meters in the bottom
section of the mixer.  I can change the routing, change the mute/solo status
of my playback channels etc - but nothing ever appears on those bottom

> 5) If you DO have playback levels, but your DON'T have output levels, it
> means that somehow the routing to your outputs has been turned down.  Just
> say for instance that there are levels in playback 1+2.  If you click the
> box below the fader you can change the outputs that those channels are
> going to, and usually when you do, it by default is turned down.  So if
> you want the playback to go out to channels 15+16, press the button and
> select A2 7+8.  Then bring the level up and you should see levels
> appearing in the 'outputs' section under channels 15+16.
I've done all that but nothing will make the signal appear on those bottom
meters.  Along the way, I did realise that the routing doesn't actually work
until you've routed a channel and then moved a fader.  However, in an
earlier post, I mentioned that there's a loudpseaker icon on
my menu bar.  If I click on it, a fader drops down, supposedly to adjust my
audio volume.  That fader is permanently set at minimum and can't be
increased.  I can't help feeling that this is the cause of my problem.

> BTW once you do have everything running, there is another tool called
> hdspconf.  This is used to make sure that your wordclock is synced to the
> same sample rate as your outboard gear,
I've already discovered hdspconf and I've played around with various
settings - e.g. Internal sync 48.0Khz, Internal sync 44.1Khz etc.  Nothing
makes any difference.  Interestingly, hdspconf contains a replica of that
drop down fader that I mentioned above, which is called (rather bizarrely)
"Volume on system sample rate"..  Presumably that means something to someone
but it doesn't mean anything to me.  However, just like the fader that
I mentioned earlier, it can't be set at anything higher than minimum value.

Thanks for all your patience with this Andrew.  OpenSUSE is on a separate
partition so I can swap between the two without doing any damage.  I'm
rather busy today but I'll be playing with OpenSUSE over the weekend.
Apodio has also been mentioned to me as a distro worth trying.
Unfortunately, I gather that it's based on Mandriva which I've already tried
and rejected.

In total, I've been faffing around with Linux for some 12 weeks, making
painfully slow progress.  OpenSUSE is now the seventh distro I've tried and
every one of them has had some kind of show stopping problem.  By contrast,
it took me just 15 seconds to install my new card under Windows and it works

Much as I want to be involved with Ardour, I'm afraid that Linux is really
turning out to be too much like hard work!!  I'm still happy to contribute
to any Windows development but it's starting to look like Linux is not for
me, I'm afraid.... :-(

Thanks to all who've helped.


More information about the Ardour-Users mailing list