[Ardour-Users] Ardour 2.0.5 released

John Emmas johne53 at tiscali.co.uk
Fri Aug 3 14:36:45 PDT 2007

Hi Paul,

Sorry I had to leave iRC earlier.  I left 2.0.5 building and by the time I
returned home it had completed (apparently successfully).  Unfortunately,
when I try to run the new version I get a message about checking symbols,
then the following error:-

Undefined symbol: _ZN6ARDOUR7ProfileE

It happens almost immediately if I try to load Ardour from a terminal (and
Ardour never starts).  My previous version still runs fine.  I've done a
complete rebuild but I still get the same error.  Just wondered if this
might mean anything to you?



----- Original Message ----- 
From: "Paul Davis" <paul at linuxaudiosystems.com>
To: "Brett Clark" <Brett at ciscoinc.com>
Cc: <ardour-users at lists.ardour.org>
Sent: 03 August 2007 19:12
Subject: Re: [Ardour-Users] Ardour 2.0.5 released

> On Fri, 2007-08-03 at 14:11 -0500, Brett Clark wrote:
>> When compiling 2.0.5 from the ardour-2.0.5.tar.bz2 tarball:
>> [brett at daw ardour-2.0.5]$ scons FFT_ANALYSIS=1
>> ...
>> ....
>> g++ -O3 -fomit-frame-pointer -ffast-math -fstrength-reduce -pipe -DARCH_X86
>>  -mmmx -march=i686 -msse -mfpmath=sse -DUSE_XMMINTRIN -DBUILD_SSE_OPTIMIZATIONS
>> -fPIC -Ilibs/pbd -I/usr/include/glib-2.0 -Ilibs/sigc++2 -I/usr/lib/glib-2.0/include
>>  -Ilibs/midi++2 -I/usr/include/libxml2 -c -o
>> libs/midi++2/alsa_sequencer_midiport.os
>> libs/midi++2/alsa_sequencer_midiport.cc
>> libs/midi++2/alsa_sequencer_midiport.cc: In member function âint
>> MIDI::ALSA_SequencerMidiPort::CreatePorts(MIDI::PortRequest&)â:
>> libs/midi++2/alsa_sequencer_midiport.cc:175: error:
>> âSND_SEQ_PORT_TYPE_SOFTWAREâ was not declared in this scope
>> scons: *** [libs/midi++2/alsa_sequencer_midiport.os] Error 1
>> scons: building terminated because of errors.
>> Is there something else i need for compiling this?  I compiled 2.0.3 with
>> the same option (FFT_ANALYSIS=1) on this machine w/o any issues.
> sorry about this. it uses some preprocessor symbols that are defined by
> newer ALSA. to get it compiling, go to that line and make it look like
> this:
> if (0 <= (err = snd_seq_create_simple_port (seq, req.tagname, caps,
> then it will work without you having to upgrade ALSA. I will also remove
> this stuff, because it really doesn't seem to do anything for us.
> --p
> _______________________________________________
> Ardour-Users mailing list
> ardour-users at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org

More information about the Ardour-Users mailing list