[ardour-users] Seem to have lost all MIDI functionality in ardour2

Steven Chamberlain steven at pyro.eu.org
Mon Sep 18 20:16:28 PDT 2006


Today I realised I was no longer able to assign MIDI controllers to
faders in the ardour2 mixer window.

Forgive me if I'm mistaken, but I seem to remember this working
previously (definitely in ardour '1', but i thought this worked in
ardour2 also). I was using Ctrl+Mouse2 and clicking on the fader itself
but the popup window doesn't appear, and moving my MIDI controllers does

More interestingly, I went through ardour2's settings, enabling MIDI,
MMC, MTC from the Options menu, and enabling input and output traces in
the Option Editor window. In qjackctl I connect my sound card's MIDI
port to ardour2's only MIDI port (named "seq" - should there be
others?). However, the MIDI input trace does not display anything at all
in the terminal window. My MIDI controller includes transport control
buttons -- the 'play' and 'stop' buttons once used to display the sysex
messages in the MIDI input trace and, with MTC enabled, would start and
stop the play cursor. But I no longer see any kind of MIDI trace output.

I am currently using the latest svn (revision 918). Before that I was
trying to use MIDI in an older revision of ardour2 from svn but that
wouldn't work either.

This leads me to believe I must be just very confused, and perhaps these
functions only ever worked for me in ardour version 1. But nonetheless I
don't see why these would no longer be working in ardour2?

I notice the option in ardour2 to enable a 'Generic MIDI' 'Control
Surface'. I think perhaps I need to enable this for things to work as
intended. But this results in this error message, about which I cannot
find any explanation:

  [ERROR]: no MIDI port named "control" exists - generic MIDI control
  [ERROR]: control protocol name "Generic MIDI" could not be initialized

I also notice that when ardour2 first loads, I see the following in the
terminal window:

  ardour: [INFO]: Control surface protocol discovered: "Generic MIDI"

I have checked both the mailing list and issue tracker but from what I
can tell I am either doing something very wrong or being hit by a bug

Steven Chamberlain
steven at pyro.eu.org

More information about the Ardour-Users mailing list