[ardour-users] Jack is Jacked

Mike Fisher mrfisher_1 at yahoo.com
Thu Mar 30 08:47:23 PST 2006

ok...no jackstart in 2.6.x gotcha... I wish I could try it... 
 I'm running kernel 2.6.10 by the way.
 Somehow I've managed to really screw up my audio system here... now i can't even get the alsa modules to load... when I run /etc/init.d/alsasound start... it tells me that the modules are an invalid format.
 I did something seriously wrong... It might be better if I just scrap this installation of Gentoo and reinstall..  Its an experimental install anyway.  For me to "try" to learn Linux "do's and don'ts" I suppose...  It takes so freakin' long though.
 Tux, I love ya man... but sometimes you drive me crazy.

Paul Davis <paul at linuxaudiosystems.com> wrote: On Thu, 2006-03-30 at 07:38 -0800, Mike Fisher wrote:
> It turns out I had two installs of jack and qjackctl... I still get
> some errors though
> --> cannot write to jackstart sync pipe 4 (Bad file descriptor)
> jackd: wait for startup process exit failed

do not use jackstart to start jackd on a 2.6 series kernel. we really
need to get rui to remove this option from qjackctl. jackstart is
exclusively for use on 2.4 kernels.

> -->cannot lock down memory for RT thread (Cannot allocate memory)
> -->cannot use real-time scheduling (FIFO at priority 9) [for thread
> 147458, from thread 147458] (1: Operation not permitted)
> -->cannot use real-time scheduling (FIFO at priority 20) [for thread
> 49156, from thread 49156] (1: Operation not permitted)
> -->cannot use real-time scheduling (FIFO at priority 10) [for thread
> 65541, from thread 65541] (1: Operation not permitted)
> I'm going to try rebuilding alsa and then jack again... perhaps this
> will help

no, that won't help. you don't have permission to run apps with realtime
scheduling. the way to fix this depends a lot on which kernel you are
running and which distribution.


New Yahoo! Messenger with Voice. Call regular phones from your PC for low, low rates.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20060330/c0c24b63/attachment-0001.htm>

More information about the Ardour-Users mailing list