[ardour-users] exporting tracks?

Kevin Cosgrove kevinc at doink.com
Fri May 20 01:21:05 PDT 2005

On 27 April 2005 at 15:38, Wolfgang Woehl <tito at rumford.de> wrote:

> Kevin, ok, you tried a lot of things. Next thing you could try is build 
> ardour with "scons DEBUG=1" and run it inside a debugger:
> $ cd ardour/gtk_ardour
> $ ./ardbg
> gdb shows up, at the prompt you say
> gdb> run
> When the export crashes/comatizes ardour you can try to get a backtrace 
> with
> gdb> thread apply all bt
> (If ardour doesn't really crash though it's more complicated. You would 
> have to set a breakpoint and then apply bt)

True.  Ardour doesn't crash.  But, I did kill it, hoping for a 
backtrace.  But, I couldn't get a backtrace, probably because I
killed it?  I tried setting some breakpoints.  I started looking
in export_dialog.cc, but wasn't lucky (patient?) enough to figure out
just where to set the breakpoint to isolate my issue.  Maybe I
should have been looking in editor_export_audio.cc anyway.  Below is 
what I tried.

[kevinc at music-gtk_ardour #27] gdb ardour.bin 
GNU gdb 6.2-2mdk (Mandrakelinux)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-mandrake-linux-gnu"...Using host libthread_db l
ibrary "/lib/tls/libthread_db.so.1".

(gdb) run
Starting program: /home/local/src/INCOMING/BUILD/ardour-0.9beta29/gtk_ardour/ard
[Thread debugging using libthread_db enabled]
[New Thread 1083668672 (LWP 15979)]
[New Thread 1092254640 (LWP 16034)]
Ardour/GTK 0.9beta29
   (built using 0.589.2 with libardour 0.887.1)
Copyright (C) 1999-2005 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
This is free software, and you are welcome to redistribute it 
under certain conditions; see the source for copying conditions.
Loading UI configuration file /etc/ardour/ardour_ui.rc
Loading system configuration file /etc/ardour/ardour_system.rc
Loading user configuration file /home/kevinc/.ardour/ardour.rc
ardour: [ERROR]: MIDI: no such port device
ardour: [WARNING]: Your system generates "Mod2" when the NumLock key is pressed.
 This can cause problems when editing so Ardour will use Mod3 to mean Meta rathe
r than Mod2
[New Thread 1105619888 (LWP 16038)]
[New Thread 1114012592 (LWP 16039)]
Loading session /home/kevinc/Music/Test/drumtest1 using snapshot drumtest1
[New Thread 1124174768 (LWP 16056)]
[New Thread 1132567472 (LWP 16057)]
[New Thread 1141492656 (LWP 16058)]
Couldn't get registers: No such process.
(gdb) thread apply all bt
Cannot find new threads: generic error

> Another thing to check would be to look for jackd right after the 
> freeze. Is it alive?

Seems to be fine.

> In qjackctl -> Setup you can set a (much) longer timeout so that jackd 
> waits longer for an app to come back up again.

Longer timeout doesn't seem to work as well.

> If the above doesn't help then you should 
> /join #ardour on freenode.net to get live and way more competent help 
> from las, taybin, sampo_v2 and nick_.

I must live in a cave.  I still don't chat.  Ugh, I guess I'll have 
to learn.

> Keep a list at hand with exact 
> kernel version, jackd version, ardour version etc.

kernel is 2.6.7 of the Mandrake contrib multimedia variety to which I 
added the realcap patch.  I've confirmed that realcap is working for 
me as a user.
jack is version 3.0.0.  jackit and jackit-realtime are 0.98.1.  
qjackctl is 0.2.12.
ALSA is 1.0.6a.
Ardour is beta29.
Distribution is Mandrake 10.1.
Hardware is 2GHz Celeron, 1GB RAM, 200GB Seagate Baracuda disk.

> Your rc looks totally ok. Me being a monkey I would try the case with 
> vst disabled, but just out of a hunch. I use vst too and have zero 
> problems with it.

I tried disabling VST.  No change.

A couple days ago Esa Linna reported what looked just like what I'm 

>>I installed PlanetCCRMA's RPM of Ardour (Version 0.9beta29-1). Works fine,
>>except when exporting the session to file (wav or aiff), the system stucks
>>and exporting fails. Is this a common bug, or should I try other version of

I raced right to the ardour nightly tarball, built and tested the May 
17th version.  Alas, for me I have the same export hanging problem as 

I'm eager to try more debugging.  Should I join ardour-devel and ask 
there?  I don't want to be a pest on a developer list with a user 
question tho.  But, this is starting to look like the kind of thing 
that a developer would be best able to coach me at.


More information about the Ardour-Users mailing list