[ardour-users] Saving tragedy: "cannot save state" -> "cannot understand ardour file" :///

mArukqs marukas at hardcore.lt
Sat Mar 5 09:44:52 PST 2005


Today I was trying to mix a 4 track song which was recorded yesterday.
My PC config:
Fedora Core 3, PLANET CCRMA kernel
Celeron 900MHz 512 RAM,
Audigy soundcard,
etx3 for system, separate IDE disk with reiserfs for ardour projects.
Ardour beta 27 from PLANET CCRMA.

After one hour of work (I was clicking save button from time to time) I
found that I cannot save my project anymore.

Ardour was reporting something like "cannot save state".

I was trying to click Save and to click Save and Snapshot - but the error
message was the same.

I closed Ardour and tried to open saved ardour project.
Unfortunately I got an error "cannot understand ardour file".

Then I tried to open saved ardour project xml file with text editor -
unfortunately XML file was corrupted - it was broken/not completely saved

The last strings looked like:

    .... blablabla various region information ...
    ... there was information for another region ...

So it seems that XML file was broken - <Regions> tag was not closed and
many other tags, which I found in my other ardour project XML files, were

I created a new project and I had to do all the mixing of the song from

How can I avoid such a problem in the future.

Please, Help


More information about the Ardour-Users mailing list