[ardour-users] sync source = MTC(SMPTE) ???

Kevin Cosgrove kevinc at doink.com
Fri Feb 11 08:54:01 PST 2005

OK, I figured a bunch of stuff out.  First I compiled ardour
0.9beta26, one year newer than the Mandrake contrib 0.9beta10.  I
still had troubles, then on a hunch I removed my ardour.rc file
and let beta26 recreate it, which it did well except that I had
to change "C1D0" in the line below to "C0D0".

<MIDI-port tag="hw:0" device="/dev/snd/midiC0D0" type="alsa/raw" mode="duplex"

Then I altered the lines below to specify "hw:0" instead of "seq".

    <Option name="mtc-port" value="hw:0"/>
    <Option name="mmc-port" value="hw:0"/>
    <Option name="midi-port" value="hw:0"/>

The new ardour.rc file created by ardour also fixed a number of
warnings I was getting complaining about key binding problems.
It looks like the ardour.rc file created by beta10 has some stuff
in it that beta2[46] doesn't like.

Next I set the Sync parameters like so:

   slave to MTC
   jack time master
   smpte offset 00:18:00:00
   smpte frames/second 30FPS no-drop

And, the MIDI parameters like so:

   receive MIDI parameter control
   receive MMC

When I start ardour now I see this output:

Ardour/GTK 0.9beta26
   (built using 0.573.0 with libardour 0.868.1)
Copyright (C) 1999-2005 Paul Davis
Some portions Copyright (C) Steve Harris, Ari Johnson, Brett Viren, Joel Baker
This is free software, and you are welcome to redistribute it 
under certain conditions; see the source for copying conditions.
Loading UI configuration file /etc/ardour/ardour_ui.rc
Loading system configuration file /etc/ardour/ardour_system.rc
Loading user configuration file /home/kevinc/.ardour/ardour.rc
ardour: [ERROR]: MIDI: no such port device
ardour: [WARNING]: Your system generates "Mod2" when the NumLock
        key is pressed. This can cause problems when editing so
        ardour will use Mod3 to mean Meta rather than Mod2

Apparently ardour still doesn't like my setting of the midi-port.  I 
also tried "seq", ardour's default, but that didn't work either.  How 
can I solve this?

What does the "Mod2" part of the message mean?

At this point I can press play on my ADAT and ardour will follow
along.  One time I pressed stop on the ADAT and ardour stopped
too, but that only happened once, and usually ardour just keeps
on playing after the ADAT stops.

Now to SMPTE offset, I need to record on the ADAT tape between
00:18:00:00 and 00:24:00:00, explaining my SMPTE offset above.
I've noticed some odd behavior with ardour related to this.  When
I stop the ADAT I then press stop in ardour too.  The first time
I press stop in ardour the cursor returns to 00:00:00:00.  The
second time I press stop in ardour the cursor returns to *about*
00:18:00:00.  Frequently it returns to something within 5 seconds
of that time.  Can I get ardour to always return to 00:18:00:00

My work-around, which doesn't always work the first time, is
to set the ADAT to 00:18:00:00, manually move ardour's cursor
to 00:18:00:00, and then press play on the ADAT.  Much of the
time this is enough to get ardour to think the song starts at
00:18:00:00.  But, too often ardour will jump to something within
a few seconds of where the ADAT is playing and continue to play
with that time offset relation to the ADAT.  Is there any way to
always keep the ADAT and ardour in sync?

The display that ardour insists on giving me ranges from
00:00:00:00 to about 00:24:00:00.  Even if I zoom in on this
range, when I click on stop, the display range will change.  I've
been playing with markers for start and end, but I haven't hit
on anything yet that lets me snap the display to a marker.  I
haven't started playing with regions or chunks yet.  Is there
a way to tell ardour that I only want to see 00:18:00:00
to 00:24:00:00?  When I mix my tracks, will ardour include
00:00:00:00 to 00:18:00:00 in the output file(s)?

Thanks all.....


More information about the Ardour-Users mailing list