[ardour-users] exporting tracks?

Kevin Cosgrove kevinc at doink.com
Tue Apr 26 22:48:25 PDT 2005

On 26 April 2005 at 10:08, Wolfgang Woehl <tito at rumford.de> wrote:

Thanks for writing Wolfgang.  I hope I include enough info below
to be useful.

> These are symptoms I've never seen. Export does have problems  
> though (Loosing realtime capabilities) but they show only      
> after exporting.  Could be your jackd setup. Could be a nasty  
> plugin even. Latest beta is 29 so try that first.              

I've tried jackd in realtime mode (-R) and non-realtime mode.
Each of those cases I've tried with the realcap module loaded
with root only privileges, unloaded, and loaded with privileges
for those in the "audio" group.  My account is a member of that

I use qjacktcl to start jack.  The command it runs is:

    /usr/bin/jackd -R -dalsa -dhw:1 -r44100 -p2048 -n2

As a non-root user I get realtime capabilities via the
realcap module which loads at boot time via this line in

    /sbin/modprobe --first-time --ignore-install realcap gid=81

I didn't activate any plugins.  I recorded some tracks dry and
tried to export.  I was trying beta28.  I've upgraded now to
beta29.  With respect to my peculiar export troubles beta29 is
equivalent to beta28 in what I can observe.

> > >   When I try to export a session to WAV Ardour quietly
> > > freezes and dies. Is this happening to anyone else ?
> >
> > This looks to me like *exactly* my problem.
> Not to me. Isn't "quietly freezing and dying" much more elegant
> than putting up load on your machine for 10 minutes?

Maybe I should better describe the symptoms.  I export my session
to stereo WAV file at 16-bit depth and 44.1kHz rate on an Intel
machine.  When I click "Export" the progress bar moves to the
right and almost finishes.  The song cursor moves to the right,
stopping exactly 1 measure before the end of the song.  At this
point ardour stops responding to any input I might give it, and
the CPU runs at 100%.  Once I waited 10 minutes for my 2 minute
song to finish exporting; this on a 2GHz Celeron with 1GB RAM and
200GB disk.  When I kill ardour the CPU runs under 5%.  If I wait
long enough -- a minute or two -- while ardour grinds, then the
exported file seems intact and sounds like what I'd expect.

I guess my experience isn't exactly "quietly freezing and dying"
in that ardour didn't die; it slipped into a coma maybe.

> > Maybe the realcap kernel module, started with the GID of
> > the audio group of which I'm a member, is showing the same
> > trouble?  If so, maybe starting jack without the realtime
> > option would solve this?
> I suppose you already tried. What gives?

I hadn't tried that when I wrote my last email since I was away
from that computer at the time.  I've since tried it without
success.  Details of my attempts related to realcap are earlier
in this message.

In the ardour-dev mailing list archives I found a thread titled 
"workaround for the "silent export" bug using beta19?"  This is Paul 
Davis' response in one of those messages:

    > hit by the dreaded "silent export" bug.  I know this is
    > fixed in CVS now, but I *really* don't want to change ardour
    > versions in mid-project.  I'm afraid I might lose everything
    > we've done.
    > Is there some way to get around this bug using beta19?

    disable the "Sync to JACK" option for positional sync,
    returning to "Internal".

So, one of the things I tried was to set my positional sync to 
"Internal".  That didn't work either.

ardour.rc things have mattered in the past for other issues.  I
can't see how this might be the case now, but here is the config
for things other than key-bindings in my ardour.rc:

  <MIDI-port tag="hw:0" device="/dev/snd/midiC0D0" type="alsa/raw" mode="duplex"/>
  <MIDI-port tag="hw:1" device="/dev/snd/midiC1D1" type="alsa/raw" mode="duplex"/>
  <MIDI-port tag="seq" device="ardour" type="alsa/sequencer" mode="duplex"/>
    <Option name="minimum-disk-io-bytes" value="262144"/>
    <Option name="track-buffer-seconds" value="5.000000"/>
    <Option name="mute-affects-pre-fader" value="yes"/>
    <Option name="mute-affects-post-fader" value="yes"/>
    <Option name="mute-affects-control-outs" value="yes"/>
    <Option name="mute-affects-main-outs" value="yes"/>
    <Option name="solo-latch" value="yes"/>
    <Option name="mtc-port" value="hw:0"/>
    <Option name="mmc-port" value="hw:0"/>
    <Option name="midi-port" value="hw:0"/>
    <Option name="jack-time-master" value="no"/>
    <Option name="trace-midi-input" value="no"/>
    <Option name="trace-midi-output" value="no"/>
    <Option name="plugins-stop-with-transport" value="no"/>
    <Option name="no-sw-monitoring" value="yes"/>
    <Option name="stop-recording-on-xrun" value="no"/>
    <Option name="stop-at-session-end" value="no"/>
    <Option name="auto-xfade" value="yes"/>
    <Option name="no-new-session-dialog" value="yes"/>
    <Option name="timecode-source-is-synced" value="yes"/>
    <Option name="auditioner-left-out" value="alsa_pcm:playback_2"/>
    <Option name="use-vst" value="yes"/>

Is there anything else I should try, or any other information I 
should provide?

Thanks much again...


More information about the Ardour-Users mailing list