[ardour-users] Refugee from Windoze/Cubase -drowning in Linux/Ardour

Keith Smith kah.smith at shaw.ca
Tue Apr 19 20:58:29 PDT 2005

On Tue, 2005-04-19 at 18:54 -0700, Mark Knecht wrote:
> On 4/19/05, Keith Smith <kah.smith at shaw.ca> wrote:
> > Thanks again and yet again.
> > I guess we both know "But what?" is a rhetorical question? :)
> > 
> > Here's :
> > [ks at S01060050da7307e1 ~]$ ls /usr/local/bin
> > jack_bufsize     jack_impulse_grabber  jack_monitor_client
> > jack_transport
> > jack_connect     jack_load             jackrec              jack_unload
> > jack_disconnect  jack_lsp              jack_showtime
> > jack_freewheel   jack_metro            jack_simple_client
> > [ks at S01060050da7307e1 ~]$
> > I see the same file names in /usr/bin, so I can just nuke these?
> The question is vague. You can nuke the duplicates in /usr/local/bin.
> Never nuke stuff in /usr/bin. Better to uninstall RPMs using Synaptic,
> provided through the Planet.
Sorry. To be clear, it was the files in /usr/local/bin that I nuked.
> > Whoops I just did! I know that seems a bit brave, but here's what
> > happened.
> > Just before I began this reply things were going rather well, but as you
> > noticed, without realtime.  I had just recorded 8 tracks from the Roland
> > to Ardour and was piling on some plugins to see what would happen.
> that sounds good.
> > 
> > So, I closed Ardour and restarted Jack in Realtime, and recalled the
> > same project in Ardour. Well, things started to get a bit bumpy. Jack
> > (or Ardour) refused to make connections automatically. I was able to
> > make a few manually and then Ardour crashed when playing back (actually
> > hung the whole system).
> What version of Ardour? The Planet? CVS tarball?
Planet Beta 28. I haven't found the courage to play with the CVS and
tarball stuff.
> > 
> > I rebooted, disk checked and tried again with the same project and
> > Ardour crashed while I was making the Jack connections manually. So I
> > rebooted and tried again with a different Ardour project and everything
> > was fine. I've no idea, but I wonder if the first project got corrupted
> > on the first crash.
> A few people have reported things like this. Personally I haven't seen
> it. I have seen Ardour having connection problems when I add too many
> tracks at the same time, but that doesn't corrupt the session file in
> my experience.
> > Before this last boot with the different project I nuked the files
> > listed above. Maybe that was the problem? Argh!! I know. Bad Detective!!
> Well, possibly. I don't know the revision numbers on the two versions
> of Jack. Maybe dropping back to /usr/bin was an older version and that
> causes a problem. Not sure.
The two jacks were 0.99 and 0.99.36. The one thats left and running is
> My over-riding suggestion to you though is to sick well within the
> boundries of what the Planet installation provides for now. Don't go
> wandering too far outside of that set of packages until you are more
> familiar with the tools, what they do and how to understand what is
> causing the problem. Take a month and jsut use what Fernando provides.
> I think that you'll learn a lot about running your system and better
> understand what is flaking out when somethign does.
> Just my 2 cents.
Sounds like at least $2 worth. I guess that leaves vstserver out for a
while (sob), but it makes good sense. Now that we've got the Jack thing
sorted, there are a few other things that work now, like Hydrogen,
amsynth and I don't know what else, so I've got lots to keep me occupied
while I get used to this. (Not to mention actually getting to try some
work with Ardour!)

I seem to be doing most of my email on Linux now, and have the basic
things on my palm synced. The trouble there is that I use a lot of 3rd
party palm software -databases for billing etc, but the big things that
will keep me in Windows for a while are Finale, and all those VST
plugins for Cubase, plus Reason, FL Studio and Garritan. Don't know why
I should cry too much over the synth stuff though. 99.9% of what I do is
straight audio.
> > 
> > Re the cards:
> > I have done the modprobe changes suggested on the CCRMA pages, so I
> > think I'm OK there.
> > 
> > But in connection with that and with Paul's question about these
> > RPC-1's, I should note that in order to get jack going I had to spec
> > Input and Output channels as 0. I'm assuming that's because these cards
> > have no analogue I/O. Jack seems quite happy with that, and lists Inputs
> > and Outputs as pcm's.
> Humm....I ALWAYS run with those at 0 in QJC. I didn't even notice them before!
> > 
> > Playback goes through the Roland VS-2480 inputs/ dac and on to the
> > amp/spkrs. I suppose one of the next things to do is to try different
> > sample rates on the VS-2480 to try to find out what's actually
> > controlling the sample rate with this combination of hardware.
> > 
> > I've stayed away from using the ICE1712 multi's in Qjackctrl. Does that
> > make sense to you?
> Yes. Jack will talk to only one sound card. When you build a multi you
> are going outside of Jack in terms of guaranting that both cards are
> in sync. This is easier under Windows for many cards than it is under
> Linux. My RME cards do fine with syncing to other sources (ADAT,
> spdif, Word Clock) but I've heard that others do not. Stick with a
> single card for now.
> > 
> > Oh, and thanks for the heads-up on configure compile install. The veil
> > lifts very slowly, but every little bit helps!
> > 
> Totally cool. 
> Have a great evening.
> - Mark
You too!

More information about the Ardour-Users mailing list