[ardour-users] gtk+ version conflicts

bizshort at earthlink.net bizshort at earthlink.net
Sun Sep 19 11:35:14 PDT 2004

I have a problem with ardour and gtk+.  ardour ./configure wants exactly
version gtk+-1.2.8.  this version is present and was compiled from a
tarball.  but initially, gtk+-1.2.10.deb was installed and I don't know
how to remove it without breaking several (.deb) dependencies requiring >=
gtk+1.2.10.  both libraries reside in /usr/lib, so I don't think a change
in ld.so.conf or LD_IBRARY_PATH will help.  ardour's configure complains

+++++++++++++++++ snip ++++++++++++++++++++++

checking for GTK - version >= 1.0.0...
*** 'gtk-config --version' returned 1.2.8, but GTK+ (1.2.10)
*** was found! If gtk-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If gtk-config was wrong, set the environment variable GTK_CONFIG
*** to point to the correct copy of gtk-config, and remove the file
*** before re-running configure
configure: error: *** gtk-ardour requires GTK+, but it doesn't appear to
be installed
configure: error: /bin/sh './configure' failed for gtk_ardour

++++++++++++++++  snip  ++++++++++++++++++++

is there a way to tell ardour to look at gtk+-1.2.8?  it seems like this
would be a common problem.  any suggestions?  tia.  --patrick

More information about the Ardour-Users mailing list