[ardour-users] Unable to add more tracks

Third Option thirdoption at hotmail.com
Mon Oct 11 16:29:54 PDT 2004

well I tell ya - I've had sessions of 32 tracks (that's the limit) and I can
do that - I have run into this kind of thing, like I said, but I can always
hack my way around it

----- Original Message ----- 
From: "Mark Knecht" <markknecht at gmail.com>
To: "Wolfgang Woehl" <tito at rumford.de>
Cc: <ardour-users at lists.ardour.org>
Sent: Monday, October 11, 2004 5:04 PM
Subject: Re: [ardour-users] Unable to add more tracks

> On Mon, 11 Oct 2004 16:04:56 +0200, Wolfgang Woehl <tito at rumford.de>
> > > > > and then Ardour adds a mono track.
> > > >
> > > > Try increasing the -p value given to jackd (not the -p given to the
> > > > alsa backend), that's "Port Maximum" and shows up on qjackctl's
> > > > setup page.
> > >
> > > will try when I got booted up. However I think it's currently set to
> > > something like 2. Why would this limit me to 9 stereo tracks?
> >
> > Erm, the default in qjackctl is 128, and this is about *jackd's* -p
> > option (*not* the alsa backend -p option). It increases the amount of
> > memory jackd allocates for ports. Looks like
> >
> > /usr/local/bin/jackstart -R -p512 -dalsa -dhw:0 -r48000 -p1024 -n2
> >                             ^^^^^
> >
> Tried it. Ardour allowed me to add one more stereo track, then it
> defaulted back to only allowing me to add mono tracks.
> More info. I closed Ardour, restarted both Jack and Ardour, and then
> restarted the session. At this point I tried adding a single stereo
> track. Earlier I was telling it to add 5-10 stereo tracks at a time.
> This time, doing only one, it added it. I then added another, and
> another, and another, one at a time. No problems until I got to number
> 10 again and then it dies on me and says it cannot add any more giving
> me the message:
> [ERROR]: IO: cannot register input port Audio 23/in 1
> [ERROR]: cannot configure 2 in/2 out configuration for new audio track
> at which time it still adds a track, but incorretly adds a mono track.
> so I close, shut down Jack, restart Jack and the session again and it
> lets me go on adding tracks. I now have 23 stereo tracks in the
> session. However, for whatevver reason, at this point I hit the
> transport and the session does not roll... Maybe if I stop and restart
> the session again???
> Which it did just fine. So now Ihave an Ardour session with 23 stereo
> tracks playing. Only the first 13 tracks have any audio in them, but
> it is running on my laptop at -p64/-n2 with no xruns so far...
> I think something needs to be looked at. Have the developers made any
> large (very large, silly large) sessions?
> - Mark
> _______________________________________________
> ardour-users-ardour.org mailing list
> ardour-users at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org

More information about the Ardour-Users mailing list