[ardour-users] Jack uses 100% CPU and can't be killed

Mark Knecht markknecht at gmail.com
Tue Nov 30 10:25:23 PST 2004

On Tue, 30 Nov 2004 12:40:34 -0500, ross at lug.udel.edu <ross at lug.udel.edu> wrote:
> On Tue, Nov 30, 2004 at 08:18:45AM -0800, Mark Knecht wrote:
> > On Tue, 30 Nov 2004 10:58:33 +0000, Ben Edwards <funkytwig at gmail.com> wrote:
> > > When I run jack with qjackctl it coplains about ALSA/midi/patchbay.  I
> > > went on IRC and as a result tried to start jack anyway.   It then
> > > consumed 100% cpu.  I couldent run top or ps!  In fact I couldent even
> > > shut down the PC properly - I had to hold my finger on the power
> > > button for 10 seconds to do a hard shutdown.
> > >
> > > BYW are the error messages loged to a file - I cant even copy/paste
> > > them from the message window.
> I can pretty much guess what's going on.  You're running a 2.6 kernel
> right?  I had exactly the same symptoms and decided to stick with 2.4.
> I'm not too sure of what's going wrong, but under recent 2.6 kernels,
> when a realtime application runs, it consumes tons of CPU and locks up
> a lot of system function.  The odd thing --- I could still use any
> browsers or shells I had already started.  Any file access would lock
> a process solid in an instant.
> Like I said - I gave up, went back to 2.4.  The Jack FAQ has some
> notes on Jack maybe working with LD_ASSUME_KERNEL=2.4.19.  I don't
> remember if I had any luck with that.  I assume no, else I'd have
> stuck with 2.6.
Possibly he's having this sort of problem. Good for him to post the
info like I asked. However, with help offline from Ingo, Lee Revell
and Fernando I've got none of these problems on any of my 2.6


Stable, low CPU usage and less than 1mS latency on my laptop.

More information about the Ardour-Users mailing list