[ardour-users] jackd problem: pcm failed

Thomas H. George xyz at spininternet.com
Sat May 29 09:10:06 PDT 2004

This message originally posted to ardour-users-ardour.  I received two 
replies and tried to answer them from mutt.  My answers never appeared 
in the list or the archive.

I have installed alsa, patched a 2.4.22 kernel with preempt and 
lowlatency, compiled the kernel with Sound Card Support,  Creative 
SBLive! and OSS Sound modules as modules, set kernel.lowlatency=1 and 
copied asoundrc to ~/.asoundrc, opened a terminal in the X display, 
switched to root and entered jackd -R -d alsa - sblive.

jackd aborts with the message:"pcm.c:690: snd_pcm_nonblock: Assertion 
'pcm' failed."

What am I missing?

Tom George

Philcorda asked:  What's in .asoundrc?


    pcm.sblive {
       type hw
       card 0

    pcm.ctl {
       type hw
       card 0

Philcordia asked:  Is ARTS or esound running?

Answer: I don't believe so.  top shows only one active file, top itself.

Philcordia asked: Have you tried jack with -S or -P?  Does jackd without 
-d sblive do anything?

Answer:  When I started jack it wanted to rip a cd.  jackd -R -d alsa 
and jackd -R -d alsa -d hw:0 give the same result as above.

Philcordia asked:  Maybe some stale temporary files.  Where did you 
configure jact?

Answer:  I didn't.  I used apt-get install jackd to get the debian 
package and read user-howto.gz.  There is no mention of configuration or 
temporary files and I cannot locate jact in my system.

A final note:  My objective is to capture input from my phonograph, 
remove cracks and clicks and write the result to a cd.  The phonograph 
input is to the sblive card, the output from the card is to my stereo 

Tom George

More information about the Ardour-Users mailing list