[ardour-users] jackd problem: pcm failed

philicorda philicorda at ntlworld.com
Wed May 26 17:33:39 PDT 2004

Thomas H. George wrote:

> I have installes alsa, patched a 2.4.22 kernel with preempt and 
> lowlatency, compiled the kernel with Sound Card Support,  Creative 
> SBLive! and OSS Sound modules as modules, set kernel.lowlatency=1 and 
> copied asoundrc to ~/.asoundrc, opened a terminal in the X display, 
> switched to root and entered jackd -R -d alsa - sblive.
> jackd aborts with the message:"pcm.c:690: snd_pcm_nonblock: Assertion 
> 'pcm' failed."
> What am I missing?
> Tom George
> _______________________________________________
> ardour-users-ardour.org mailing list
> ardour-users at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-users-ardour.org
Damm. I've had this, but I can't remember what caused it. :)
Some questions...
What's in that .asoundrc file?

Is ARTS, esound or any other sound server running? If so, kill them.
Some sound servers take a bit of beating to stop the coming back!

Have you tried starting jack with -S to force it to try 16bit samples?
Have you tried -P to force playback only? (just to see if it works).
Does starting Jackd without -sblive do anything?

More information about the Ardour-Users mailing list