[ardour-users] Question: Suse 9.1 / AMD 64 / Echo Audio Drivers [SOLVED]

Anthony DiSante orders at nodivisions.com
Fri May 21 18:14:29 PDT 2004

tito at rumford.de wrote:
>>>The echo driver is developed by Giuliano Pochini who has done
>>>terrific work so far in making the mixer functionality etc.
>>>available as linux apps. Couple of weeks ago i tested it with a
>>>layla20. Worked superb.
>>I'm trying to get my friend's layla20 to work in Gentoo linux, and so
>>far have not succeeded.  I'm following the instructions on this page:
>>...and using alsa 1.0.4.  I can modprobe snd-layla20, and then that
>>and a few other snd* things show up with lsmod, but aplay always
>>reports this:
>>aplay: main:507: audio open error: No such device
> Contact Giuliano Pochini <pochini at shiny.it>, he knows the wire and he's 
> very helpful.

Thanks for the suggestion.  I contacted Giuliano, and he made quick work of 
my problem  :)

Apparently some layla20s are "slow" and the solution was this:

In the file Echo_Dsp.h look for this line:

#define HANDSHAKE_TIMEOUT   10000   // SendVector command timeout (10ms)

and write a longer timeout. 100000 should be enough.


More information about the Ardour-Users mailing list