[ardour-users] ALSA found es1371, but no jackstart

Keith kmceng at yahoo.com
Tue Jun 15 03:14:52 PDT 2004

First, THANK YOU for your patience and help. Especially Torbjörn
for your hard work on your website. VERY nice!  
I FINALLY found the instructions for realcap--at the END of the kernel 
installation.  I had stored them away and forgot about them when I 
was rushed on Saturday....My Bad!

But, I don't really know what actually fixed it. I tried a fresh install of 
Mandrake 10.0 on another HDD, new kernel etc, etc,
but never got that to work either.

So back to first drive and ALSA started up at boot! Wha?
Turns out modprobe.conf isn't MY editing! 
Probably configuring from X using the drake tools caused it to get 
rewritten with all the alsa aliases FIRST, then the following:

install snd-ens1371 /sbin/modprobe --first-time --ignore-install snd-ens1371 && { /sbin/modprobe
snd-pcm-oss; /bin/true; }
install usb-interface /sbin/modprobe usb-uhci; /bin/true
remove snd-ens1371 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time
--ignore-remove snd-ens1371

This dosen't look right to me but I'll leave it for now.

I fixed modprobe.preload:
"# capabilities
realcap "

and rebooted.
  # modprobe realcap any=1 allcaps=1 
was accepted.

But jackstart stil  cannot get realtime capabilities, 
current capabilities are:
           =ep cap_setpcap-e
blah blah suitable kernel blah =eip"

I recompiled jack and installed using
./configure --enable-capabilites;make;make install;
but still with same results. 

So I tried:
$ jackd -R -d alsa &   and that was accepted, but complained about:
JACK: unable to mlock() port buffers: Operation not permitted
cannot set thread to real-time priority (FIFO/20) (1: Operation not permitted)
cannot use real-time scheduling (FIFO/10) (1: Operation not permitted)

Tried ardour and momentarily saw the startup shell for the first time.
Then it flashed a picture and disappeared.
Well, still a bit more work to do....but very encouraging.

Ardour/GTK 0.514.3 running with libardour 0.814.2
ardour: [WARNING]: Without a UI style file, ardour will look strange.
Please set ARDOUR_UI_RC to point to a valid UI style file
Loading UI configuration file
Loading system configuration file /etc/ardour/ardour_system.rc
Loading user configuration file /etc/ardour/ardour.rc
Warning: L"/usr/local/lib/libfst.so" not accessible from a configured DOS drive
Warning: L"/usr/local/lib/libfst.so" not accessible from a configured DOS drive
wine: cannot find '/usr/local/lib/libfst.so'

well '/usr/local/lib/libfst.so' is there but it has a '*' after it...

I'll keep reading...after making some coffee!!!!


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the Ardour-Users mailing list