[Ardour-Dev] 2.0-ongoing build - Scons error - can't find libusb

Paul Davis paul at linuxaudiosystems.com
Sat Mar 29 14:54:27 PDT 2014

the libusb-based tranzport support is not worth supporting/building.

On Sat, Mar 29, 2014 at 4:05 PM, John Rigg <ardev3 at jrigg.co.uk> wrote:

> I've got a fresh build of 2.0-ongoing installed and working on a Debian 7.4
> amd64 system, except for Tranzport support. Scons reports that libusb
> can't be
> found. I've installed the Debian packages libusb-dev, libusb-1.0-0-dev and
> libusb++-dev. I've tried adding symlinks to libusb.h in /usr/local/include
> and
> /usr/include, along with symlinks in /usr/lib to the actual libs in
> /usr/lib/x86_64-linux-gnu, but it still doesn't work. I suspect there may
> be a
> problem with the libtool version, but so far I've been unable to build the
> current libtool from git due its insistence on trying to build a load of
> documentation (which I don't want to install the large and bloated deps
> for).
> Anyone encountered this and/or have a workaround?
> John
> _______________________________________________
> ardour-dev mailing list
> ardour-dev at lists.ardour.org
> http://lists.ardour.org/listinfo.cgi/ardour-dev-ardour.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-dev-ardour.org/attachments/20140329/6f9656bb/attachment-0001.htm>

More information about the Ardour-Dev mailing list