[Ardour-Dev] Launching Ardour (Mixbus actually) from a command line

Paul Davis paul at linuxaudiosystems.com
Thu Jul 15 05:11:24 PDT 2010

On Thu, Jul 15, 2010 at 7:04 AM, John Emmas <johne53 at tiscali.co.uk> wrote:
> Message for Paul or Ben....  I just tried you on IRC but it's probably a bit early yet.
> I'm trying to track down a problem for Ben and have just built Mixbus this morning (on Linux).  To track the problem down I needed to add some debugging to print stuff to stderr.
> Strangely though, I can no longer launch Ardour (Mixbus) from my command line.  It still launches fine from my desktop icon but if I open a terminal window, navigate to /usr/local/lib/ardour2/ and type "./ardour-2.8.11" I see this error:-
> error while loading shared libraries: libardour.so: cannot open shared object file: No such file or directory

this would likely never have worked unless you had hacked your
environment in ways that i would consider unadvisable.

the way to run ardour is *always* to run a shell script. the program
called "ardour" is that script, and it sets LD_LIBRARY_PATH so that
libraries are discovered. if you want to run a non-installed version,
then you cd to the gtk2_ardour directory, and run ./ardev, which also

ardour needs to find several "private" shared libraries when it starts
up, hence the need to set LD_LIBRARY_PATH so that they will be


More information about the Ardour-Dev mailing list