[Ardour-Dev] Ardour 2.3 build problems

John Emmas johne53 at tiscali.co.uk
Mon Mar 3 07:22:58 PST 2008

Hi Paul,

I've encountered another one of my strange "funnies" when building Ardour
and I just wondered if it might make any sense to you.  Here's what

I was previously running Ardour 2.1 on both my laptop & desktop machines
(both from the 2.0-ongoing branch and both would have been the same svn
revision but I can't remember what number).  A few days ago I did a svn
update on the laptop machine, bringing it up to svn 3117.  This built
perfectly with all the new features.  I then tried doing the same thing on
my desktop machine.  Although it built, after the install there was a whole
bunch of stuff missing - notably, no libardour_tranzport.so and only 5
drop-down menus on the main screen, compared to 10 on my laptop machine.

I tried various things - Debug build / Release build / svn --clean /
checking that my installed libs were the same on both machines etc.  I even
checked that the number of files were the same in my Ardour project folders
(and that they had the same numbers of bytes) but nothing would make
Ardour build properly on the desktop machine.  At one stage, through sheer
desperation, I even copied the entire directory structure (including all
files) from the working machine to the non-working machine but it still
wouldn't build correctly - even though in theory, it was now using exactly
the same files!!

Eventually, I renamed my main 'ardour' branch and did a fresh svn checkout 
to a new root branch.  This built and installed perfectly.  I then renamed 
the old branch back to its original name - lo and behold, it now builds 

It's a compete mystery to me but I'd be interested to know if that makes
sense to anyone else....



More information about the Ardour-Dev mailing list