[ardour-dev] problems exporting .wav files

Johan De Groote johan.de.groote at skynet.be
Thu Sep 9 13:39:27 PDT 2004

Hello there,

I do my recording in Ardour, as this is the only app that (almost) works for 
recording. But for editing the recording I like to use other apps. So I 
normally export regions to .wav files for further editing.

Problem is that both rezound and gwc complain about files exported by ardour 
unless I use 16bit wav files. I tried float/32bit/24bit with .wav, .raw 
and .au. Exporting .aiff did not work and gave a file error (tried float 
only). Using ardour/gtk 0.514.3 libardour 0.814.2 (ardour 0.9_beta16), 
libsndfile 1.0.9. Audacity does not seem to mind.

Rezound reads the files and gives at the end a "file read error-keeping what 
has been read". As far as I can see, the file is complete. Gwc gives a 
"soundfile not allowed" error but reads the file (however, this causes 
something to go wrong cause it further refuses to output the sound). So it 
looks as if the header or eof is malformed (this is the opinion of the people 
on the gwc mail list: the error reported comes straight from libsoundfile and 
is only passed through by gwc). I do not have problems exchanging 
files between the other apps.

Something strange -but probably unrelated- is that when doing the export of a 
selection, you see the cursor (red line) move together with the progress bar 
in the export window, and at the end of the export, the track is played for a 
few seconds. So everything is silent during the export, and then you get a 
second or two sound of the track you are exporting.

Thanks for any help,
Johan De Groote

More information about the Ardour-Dev mailing list