[ardour-dev] Fwd: [ardour-users] fst configure error

Josh Karnes jkarnes1 at austin.rr.com
Wed Oct 13 15:59:03 PDT 2004

Fernando Pablo Lopez-Lezcano wrote:
> On Wed, 2004-10-13 at 13:39, Josh Karnes wrote:
>>Josh Karnes wrote:
>>>>On which OS version (redhat/fedora/version number)? You mention you
>>>>didn't use apt, did you have to do "rpm --nodeps" for install ardour? Or
>>>>did you manually install all required dependencies?
>>>>What is the exact sequence of operations that leads to the crash?
>>>I installed with rpm -U
>>>I had already installed all of the deps, but had to upgrade jack at the 
>>>same time (had 0.94).  I was upgrading from Ardour 0.9beta11.2 which 
>>>worked fine.
>>>Exact sequence:
>>>1.  run ardour
>>>2.  open a session or create a session
>>>3.  add a plugin to a track
>>>4.  double-click the plugin or right-click and choose "Edit"
>>>5.  seg fault
>>>the rest is in the mantis bug.
>>oh and fwiw,
>>kernel is 2.4.21-1.11.rhfc1.ccrma from the planet
> I don't see how the kernel would have an influence, but at least that
> tells me that this is on Fedora Core 1 (I'll boot my laptop on the FC1
> disk to try it). On RedHat 9 I do what you do and ardour is happy. I
> just tried with Cannyon Delay and the Bode Frequency Shifter and they
> are happy being edited. 
> Have you upgraded all your other packages to the latest version? There
> may be a hidden problem with a library  having a bug (or misfeature),
> and the same so version (so that ardour does not complain). I build all
> binaries with the latest redhat/fedora upgrades installed (at the time
> of the build). Just guessing here. Another thing that occurs to me, have
> you installed libraries manually? (ie: configure; make; make install).
> Could you send me off list the list of packages you have installed in
> the machine?
> "rpm -q -a >rpmlist" will do. 
> And also the output of "ldd /usr/bin/ardour"...
> If I were you I'd reconsider, if possible, to put it on the network, you
> pretty much need that to use Planet CCRMA and stay up to date. 
> -- Fernando


I freshened some combo of dependency files and the ccrma binary works.

I don't know which ones I did, but I'll try and figure out... it was three or 
four of them.

Still can't build Ardour but who cares?

More information about the Ardour-Dev mailing list