[ardour-dev] Testing 09beta12-1 (was "Testing cvs 05/17/2004")

Wolfgang Woehl tito at rumford.de
Tue May 18 05:58:41 PDT 2004

Paul Davis <paul at linuxaudiosystems.com>:
> >* Adding a track during transport gives two errors:
> Damn, I never meant to allow that! :))
> Easily solved by just preventing it, i think.

Mmh. I just tried again with 09beta12-1. During playback I can add a 
track, arm and record to it. The audio is there and plays back as well 
-- supersmooth. I save the session, close and reopen. The audio of that 
added track is gone.

Being able to add a track during playback would smooth the workflow -- 
setting up the inputs etc. for the new track while listening. I don't 
think it's a mandatory feature but it would increase the overall 
feeling of graciousness. Well, when recording with a band it might even 
be mandatory: they want to listen, you want to setup the next step.

From what I understand about a daw's audio engine you mux all existing 
streams into the outputs, no matter if they have audio or not -- for 
latency, right? And that adding a track in the middle of that mucks up 
muxing -- is that true? Is that the reason you don't want to allow 

> >* Followup: I immediately remove the track and ardour crashes. I do
> > it all again and ardour does not crash. Well, the 3rd time around
> > it crashes. So I'll say it crashes sometimes. My hunch of this
> > being related to the visibility of the mixer strip in editor window
> > was wrong.
> I have a suspicion that this may be related to a bug that I've spent
> a good part of today working on. However, I will try to check into it
> some more. I believe that its very hard to make this happen under
> gdb.

Still happens with 09beta12-1:
New session, 2 tracks with fresh audio.
No crash with 1st add+remove during playback.
Crash with the 2nd add+remove.
Reopening that session still has the track (sometimes). Remove = 
Reopen and the track is gone (IO says correctly "Cannot connect ...")

> >* The Click fader setting is not restored upon reloading a session.

I can't figure it out: Click fader setting is sometimes restored, 
sometimes set to -inf, sometimes set to 0,0 (09beta12-1)

> >* Click (Session = 48 kHz)
> >Assigning a 2-channel 44,1 kHz wav to one of the clicks silences
> > click.
> I can't duplicate either of these two problems. Any more data/info
> you think might be relevant?

Still happens ("cannot read data from click soundfile"). The soundfile 
plays in the selector (2-channel 44,1 kHZ 16 bit signed pcm according 
to the soundfile selector). Click is back only after typing in 
"internal", saving and reopening the session. Well, if you can't 
reproduce this then there's probably something special about this 
soundfile. Don't know what though. I'll investigate. (09beta12-1)


More information about the Ardour-Dev mailing list