[ardour-dev] Ardour lab

Doug nostar at comcast.net
Sat Mar 13 10:57:38 PST 2004

First, thanks to Kjetil for mentioning the bus speed issue, that was the 
problem exactly.  The CPU dip switches are all set to AUTO by default, 
but there is a single bit dip sw behind one of the PCI slots that is set 
to ON for a 200Mhz lock, by default.  I'm now at 2400+ (2Ghz).  That'll 
learn me for not reading the manual...

Sorry about the lack of info, I'm going to put all the specs on my 
website then post results to the list, when I get so motivated :)

Here's more info:

Both PC's are running Slackware 9.1.  All software installed is from 
source.  I try to keep up with latest ardour/jackd cvs builds,and as of 
last night I was:

Ardour/GTK 0.454.0 running with libardour 0.729.0
jackd 0.95.3

tapedeck is linux-2.4.25 w/ low-lat patch and capability.h mod
athlon1 is ditto except linux-2.4.23 (soon to be .25)

They are both dual boot to 2.6.3 as well, booted into each one to get 
everything working , then went back to 2.4.x till I hear better news 
about realtime stuff.

And, now after correcting the CPU issue, tapedeck appears to be 
performing better.  I now get pretty similar performance between 
tapedeck and athlon1:

Using two projects, both 48Khz 8 track PCM:  2003-01-03 is 46min/4.1GB, 
2003-02-14 is 55 min/5.1GB

The projects load well on both machines, navigation thru project is 
great on athlon1, on tapedeck its a little slow till I carefully scroll 
from end to end once, then its great.  The bigger one requires more care 
not to get a disk stream error on tapedeck until scrolling end to end, 
then its fine.  I'm thinking there arent any real *problems* here, these 
are big projects, and I think most are accustomed to working with single 
songs at a time or?  I am adding 1GB ram to both machines (for a total 
of 1.5GB) this week, along with a seperate OS / data hard drive scheme.

Later today I will re attempt recording on tapedeck.  I get 0 xruns on 
athlon1 at -p1024, while browsing, chatting, emailing, etc.  Shooting 
for similar performance from tapedeck.

Question:  I ran top on both machines while recording, and the CPU usage 
is always 50-95%+ for ardour (the value gets split pretty evenly with X 
until ardour is minimized, then ardour takes it all), but qjackctl and 
ardour both show a common, very low value, always under 10%.  Is there 
any rhyme or reason here?

Paul Winkler wrote:
> Hi Doug,
> This message seems more suited for ardour-users list, but here's
> my impressions...
> On Sat, Mar 13, 2004 at 07:41:29AM -0500, Doug wrote:
>>/usr/local/bin/jackstart -R -t500 -dalsa -dhw:1 -r48000 -p1024 -n2 -m -H
>>Mostly I tried to get a handle on whats happening with the I/O 
>>performance on tapedeck.  I reversed roles and recorded into athlon1. 
>>Tapedeck was spitting and sputtering and snap crackle pop, burping and 
>>farting its way thru the same cubase project, while ardour, running on 
>>athlon1, proudly and flawlessly captured every embarrasing moment. 
>>Everything afterwards is pretty much inconclusive i think, till i 
>>determine whats up with that CPU thing.  I was vey happy with ardour's 
>>performance on athlon1 though.  Worst case I'll just go Nforce2 on all 
>>my machines.  I'm sure that wont be necessary though.
> Odd. You don't say what kernel version(s) you're using or
> how you set up your audio workstation (e.g. planet CCRMA 
> or Agnula or did everything "from scratch" or what)...
> This certainly sounds like hardware that is either bad or
> something is misconfigured.
> Have you been through EVERYTHING in the usual checklists?
> this is a good one:
> http://myweb.cableone.net/eviltwin69/ALSA_JACK_ARDOUR.html


More information about the Ardour-Dev mailing list