[ardour-dev] CVS report - vanishing plugins and more

Joe Hartley jh at brainiac.com
Wed Dec 1 04:09:22 PST 2004

I just tried installing the nightly CVS, and when I loaded a session I'd
worked on last night with beta21, I'd lost all my plugin definitions.

I had quite a few of these errors pop up in the logging window:

[WARNING]: programming error: PluginInsert::require_io() called with inputs/outputs = zero!

It also reported this:

[ERROR]: too many panner states found in pan automation file /tape/Meccalily-Jungle/automation/Meccalily-Jungle-pan-Audio 1.automation

This didn't seem to affect anything that I could see.

I also want to mention an annoying little thing that happens in the mixer
window.  No matter how many times I rearrange the tracks or make some
invisible, the changes don't "stick".  I'd stuck with some previous state
that was saved some time previous.  I've done a few submixes now, and
having to always go in and hide 16 tracks and re-arrange things seems
minor, but has a way of getting on one's nerves the 40th time you have
to do it!!

Finally, last night I had a repeatable crash with beta21.  We were recording
2 mono tracks, and after a flubbed take, I'd select the region in the
first track, destroy it, select the region in the second track, choose
destroy, and *bam!* - Ardour died a hard death.

I didn't bother taking out any more regions, jsut kept recording over the
existing ones.  This morning, after installing the nightly CVS, I removed
a lot of tracks, but didn't try destroying them.

Hope this helps!

       Joe Hartley - UNIX/network Consultant - jh at brainiac.com
Without deviation from the norm, "progress" is not possible. - FZappa

More information about the Ardour-Dev mailing list