[Ardour-Users] Fwd: Ardour 6.9 crashes when opening a blank template.

Robert Kugler bob at bobkugler.com
Mon Jul 18 09:18:02 PDT 2022

-------- Forwarded Message --------
Subject: 	Ardour 6.9 crashes when opening a blank template.
Date: 	Sat, 16 Jul 2022 16:33:52 -0400
From: 	Robert Kugler <bob at bobkugler.com>
To: 	ardour-users at lists.ardour.org
CC: 	bob at bobkugler.com


Sorry if this is a nuisance question, but I cannot fix the issue, and I 
dont want to reinstall

  because everything was working so well, and i saw that one person who 
removed things ended up by killing Gnome.

I have the paid verson of Ardour 6,9, running on Ubuntu  20.04.4 LTS.  
Everything was working very well.

I opened a blank template project to do some editing, and ardour 
immediately crashed (righ after I selected "new session -> empty template").

This is the first time it happened, so I rebooted the computer and tried 
again: same result. I tried it twice more with the same result.

I also tried starting Ardour in safe mode with no plugins; same crash.

I have recently installed pipewire (but Ardour was working fine with 

BTW, Ardour will open fine and play files with an existing project, and 
only crashes on a blank project.

There was a Cannonical update before Ardour started crashing, so i 
rolled the update back by restoring an earlier dated timeshift backup.

Sam crash problem.

I disabled "memory unlimited" in /etc/security/limits.conf, and that had 
no effect on the crashing.

I started Ardour6 with gdb, and got the following messages:


kugler at rodan:/etc/security/limits.d$ Ardour6 --gdb
GNU gdb (Ubuntu 9.2-0ubuntu1~20.04.1) 9.2
Copyright (C) 2020 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later 
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /opt/Ardour-6.9.0/bin/ardour-6.9.0...
(No debugging symbols found in /opt/Ardour-6.9.0/bin/ardour-6.9.0)
(gdb) run
Starting program: /opt/Ardour-6.9.0/bin/ardour-6.9.0
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Ardour6.9.0 (built using 6.9 and GCC version 6.3.0 20170516)
Ardour: [INFO]: Your system is configured to limit Ardour to 1048576 
open files
Ardour: [INFO]: Loading system configuration file 
Ardour: [INFO]: Loading user configuration file 
[New Thread 0x7fffea0ff700 (LWP 11226)]
Ardour: [INFO]: CPU vendor: AuthenticAMD
Ardour: [INFO]: AVX-capable processor
Ardour: [INFO]: AVX with FMA capable processor
Ardour: [INFO]: CPU brand: AMD Ryzen 5 5600G with Radeon Graphics
Ardour: [INFO]: Using AVX and FMA optimized routines
Ardour: [WARNING]: Could not set CPU DMA latency to 1 usec (Permission 
[New Thread 0x7fffe98fe700 (LWP 11227)]
[New Thread 0x7fffe90fd700 (LWP 11228)]
[New Thread 0x7fffe88fc700 (LWP 11229)]
Ardour: [INFO]: Loading plugin meta data file 
Ardour: [INFO]: Loading plugin statistics file 
[New Thread 0x7fffdb435700 (LWP 11230)]
[Thread 0x7fffdb435700 (LWP 11230) exited]
[New Thread 0x7fffdb435700 (LWP 11231)]
[New Thread 0x7fffd89bd700 (LWP 11232)]
[New Thread 0x7fffcef90700 (LWP 11233)]
Cannot xinstall SIGPIPE error handler
Ardour: [INFO]: Loading default ui configuration file 
Ardour: [INFO]: Loading user ui configuration file 
Ardour: [INFO]: Loading 452 MIDI patches from 
Gtk-Message: Failed to load module "canberra-gtk-module"
Ardour: [INFO]: Loading color file 
Ardour: [INFO]: Loading ui configuration file 
Ardour: [INFO]: Loading bindings from /opt/Ardour-6.9.0/etc/ardour.keys
Loading ui configuration file /opt/Ardour-6.9.0/etc/clearlooks.rc
[New Thread 0x7fffce3ff700 (LWP 11234)]
[New Thread 0x7fffce37e700 (LWP 11235)]
[New Thread 0x7fffcdac0700 (LWP 11236)]

Thread 12 "ArdourGUI" received signal SIG32, Real-time event 32.
[Switching to Thread 0x7fffcdac0700 (LWP 11236)]
0x00007fffee48146e in epoll_wait (epfd=14, events=0x7fffcdabf830,
     maxevents=32, timeout=-1) at ../sysdeps/unix/sysv/linux/epoll_wait.c:30
30    ../sysdeps/unix/sysv/linux/epoll_wait.c: No such file or directory.


Typing backtrace command:

(gdb) bt
#0  0x00007fffee48146e in epoll_wait (epfd=14, events=0x7fffcdabf830,
     maxevents=32, timeout=-1) at ../sysdeps/unix/sysv/linux/epoll_wait.c:30
#1  0x00007fffcef972cb in ?? ()
    from /usr/lib/x86_64-linux-gnu/spa-0.2/support/libspa-support.so
#2  0x00007fffcefa3c93 in ?? ()
    from /usr/lib/x86_64-linux-gnu/spa-0.2/support/libspa-support.so
#3  0x00007fffcf026b4c in ?? () from 
#4  0x00007ffff088a609 in start_thread (arg=<optimized out>)
     at pthread_create.c:477
#5  0x00007fffee481133 in clone ()
     at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95
(gdb) q
A debugging session is active.

     Inferior 1 [process 11222] will be killed.

Quit anyway? (y or n) y


Can anyone see the issue here?....It seems that it is a pipewire issue, 
but I am not sure.....

Thanks for any help....


bob at bobkugler.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20220718/d6e7dfde/attachment.html>

More information about the Ardour-Users mailing list