[Ardour-Users] "Extract LTC from audio and align video" menu option missing from "Transcode/Import Video file" popup

robertlazarski robertlazarski at gmail.com
Wed Apr 11 06:53:21 PDT 2018

On Wed, Apr 11, 2018 at 7:21 AM, Chris Caudle <chris at chriscaudle.org> wrote:

> On Mon, April 9, 2018 10:18 pm, robertlazarski wrote:
> > I confirmed that too, in the process I learned what "drop frames" are and
> > what they do.
> Yeah, I realized I only partially understood how drop frame timecode
> works, so I had to spend some time going through the details.
> The ATSC standard used for digital TV broadcast in the US and some Asian
> countries calls out 30fps and 29.97fps, I was hoping that everyone would
> just switch to straight 30fps and drop frame would go away, but I guess
> during the transition period from analog to digital broadcasts they went
> with 29.97002997002997... for compatibility, and then just never switched.
>  We're stuck with it forever probably.
For a music performance video that does post through Ardour and ends up on
youtube or whatever ... In your opinion, should I use or not use drop
frames? I'm sort of doing "option bingo" right now :-) .

> Anyway, I didn't get a chance to try stepping through the video import
> last night, but I did do a sanity check on video file import, and using a
> file I generated with ltcgen and ffmpeg I verified that I could import a
> video file and it would line up on the timeline exactly where I expected.
> I used a bitmap editor to generate a 720x480 bitmap, it was just a single
> color background with "LTC Test" text added so that I had a starting frame
> for the video.  Named test_image.bmp for reference below.
> I created an audio file with timecode starting at 6:05:29 to match your
> earlier file (length was picked as some semi-random value a little over 5
> min long):
> ltcgen -f 30/1.001df -l 00:05:32:15 -t 06:05:29:14
> time_code_test_060529.wav
> Created video with command:
> ffmpeg -loop 1 -i test_image.bmp -i time_code_test_060529.wav -c:v libx264
> -tune stillimage -c:a aac -b:a 192k -pix_fmt yuv420p -r 30000/1001
> -shortest timecode_test_video.mp4
> When I opened timecode_test_video.mp4 in Ardour it lined up right at
> 6:05:29.
> So that seems to point at something in your specific video file having
> some feature that confuses the ardour import.
> You should be able to duplicate using those command lines I pasted in
> above, you just need to create a single bmp file in a graphics editor to
> start with.

Wow, thanks for that info! I am definitely going to look deeper into that
analysis. When you say "create a single bmp file" , do you mean like Gimp?
Sorry I am a video and graphics newbie and some things I don't understand

The whole idea of this project was to use phone cameras since they are
disposable. Nice cameras with a BNC timecode input become obsolete too soon
for them to be worth it to me ymmv. However I already suspected my problems
are in the Irig DUO / phone chain somewhere.

So instead of setting up a second phone camera chain I went with a
different chain after the F8: The Zoom Q8 and a Tentacle Sync E timecode
generator. I was going to split the BNC signal out of the F8 for each
camera but the TS has LTC audio out and the cables I need.

The short story on the Q8 is it uses MOV as the video format, I figured
with ffmpeg I can convert it if need be. The audio can be embedded in the
video or recorded to separate files. It has very good L/R 1/4 audio inputs
with video quality barely competitive with the latest phones but that is ok
at the moment. It was only a little more than another Irig DUO.

This new gear is arriving Friday so I will test it out then.

> > Yes, I am using the OpenCamera app and it allows a wide range of variable
> > bit rates and fps options. I could try any combo, just let me know.
> And the app is set at 29.97fps? I'm still confused about why ffmpeg is
> flagging the video file as 29.89fps. Maybe just a rounding error since
> that original file is only 42 seconds long.  Have you tried with a file
> from that phone which is a few minutes long?
The android Moto X (2nd generation) used in the links I provided has
defaults, and my camera app just uses those unless I do "option bingo". The
frame rate the phone uses for these videos is a mystery to me. I tried
another phone (Latest Moto X) and it does that same weird fps. I also don't
understand yet why re-encoding the video frame rate didn't fix the

> Chris Caudle
Kind regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ardour.org/pipermail/ardour-users-ardour.org/attachments/20180411/024e52d3/attachment.htm>

More information about the Ardour-Users mailing list