[Ardour-Users] lv2 plugin location.

Will J Godfrey WillGodfrey at musically.me.uk
Fri Mar 11 00:27:26 PST 2016

On Thu, 10 Mar 2016 23:51:30 +0100
Robin Gareus <robin at gareus.org> wrote:

> On 03/10/2016 09:45 PM, Will J Godfrey wrote:
> > Both are identified by that command but still invisible :(  
> Ardour uses liblilv to interface with lv2, just like `lv2ls`.
> The liblilv we ship with binaries from ardour.org comes with liblilv
> configured as
>    ./waf configure
> --default-lv2-path='~/.lv2:/usr/local/lib/lv2:/usr/local/lib64/lv2:/usr/lib/lv2:/usr/lib64/lv2'

When I started this experiment there was no LV2_PATH set at all. I've since
tried a number of variations (including the above) with no improvement.

> despite http://lv2plug.in/pages/filesystem-hierarchy-standard.html not
> recommending that it should find lv2s in on Fedora just fine.
> Where did you get Ardour from? Some distros do change the ardour startup
> wrapper script and override LV2_PATH in there.

I compiled the source fetched via git. There must be something really screwy
going on with my system. I've discovered that I get the same problem with
muse3 :(

Initially it was yoshimi that I was trialing, but just in case there was a
problem with it's implementation I also tried zynaddsubfx (the plugin with
most similar characteristics) this gave exactly the same results. Move it
to /usr/lib64/lv2 and it disappears from sight.

However, zyn was originally in /usr/lib/lv2 while yoshi was
in /usr/local/lib/lv2. Swap their locations and everything works perfectly.
This suggests to me it is something specific to LV2_PATH on my machine :(

It wasn't me! (Well actually, it probably was)

... the hard part is not dodging what life throws at you,
but trying to catch the good bits.

More information about the Ardour-Users mailing list