[Ardour-Users] Compilation problem on fedora 24

Chris Caudle chris at chriscaudle.org
Fri Jul 15 08:57:35 PDT 2016

On Fri, July 8, 2016 12:13 pm, Yann Collette wrote:
> I meet some compilation problems with the current master.
> On fedora 24, the version of lv2 is 1.10.0.
> To be able to compile the current master, I needed to changes some files
> from the lv2 plugins.

I can confirm that compilation is successful with the most recent git head
and the most current Fedora updates.

Waf: Leaving directory `/home/chris/Src/Ardour/ardour/build'
'build' finished successfully (32m57.877s)

$ gcc --version
gcc (GCC) 6.1.1 20160621 (Red Hat 6.1.1-3)

$ rpm -q lv2
$ rpm -q suil
$ rpm -q serd
$ rpm -q lilv

Still not quite up to the latest versions, I noticed that the waf
configure step called out that fftw and the LV2 libraries from drobillard
were still not the latest versions (suil looks up to date, lilv and serd
are not latest).

Has fftw project even released the update with threading fix yet, or does
that still have to be pulled from the repository?

Chris Caudle

More information about the Ardour-Users mailing list